summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Allen2015-06-09 12:01:39 -0400
committerSteven Allen2015-06-09 12:01:39 -0400
commit95c00d1f3a78ea96c07deec7358eb66e52aa9d0f (patch)
treef46e1a267563373cb1ace005ebfa79ea368416a8
downloadaur-95c00d1f3a78ea96c07deec7358eb66e52aa9d0f.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff9f2773a6d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-django-localflavor
+ pkgdesc = Country-specific Django helpers
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/django/django-localflavor/
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2-django
+ source = https://github.com/django/django-localflavor/archive/1.1.tar.gz
+ sha256sums = 541e5b886504b5af39e4b2b7f116cea94daccbf3e779791456b009ec6eb36370
+
+pkgname = python2-django-localflavor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b77e690ce76b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Steven Allen <steven@stebalien.com>
+
+pkgname=python2-django-localflavor
+_pkgname=django-localflavor
+pkgver=1.1
+pkgrel=1
+pkgdesc='Country-specific Django helpers'
+arch=(any)
+url=https://github.com/django/django-localflavor/
+license=(BSD)
+depends=(python2-django)
+makedepends=(python2-setuptools)
+source=(https://github.com/django/${_pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=('541e5b886504b5af39e4b2b7f116cea94daccbf3e779791456b009ec6eb36370')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ python2 setup.py install --root=${pkgdir} --optimize=1
+
+ install -D -m 644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}