summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroi_wtf2019-02-24 20:57:42 +0100
committeroi_wtf2019-02-24 20:57:42 +0100
commit6446da9248a5dec15dc4104054c7232d050bd46f (patch)
treea4aa240fe7282b4a10af8b10fc4b310a5d74da8a
parentf9f6bccba7fb72bfa74b171d2d0a6b108aa283c5 (diff)
downloadaur-6446da9248a5dec15dc4104054c7232d050bd46f.tar.gz
upgpkg: python2-django-picklefield 2.0.0-1
upstream release See also: https://www.archlinux.org/packages/community/any/python-django-picklefield/
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdd2bb9a4262..59305bfa329f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python2-django-picklefield
pkgdesc = A pickled object field for Django
- pkgver = 1.0.0
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/gintas/django-picklefield
arch = any
license = MIT
makedepends = python2-setuptools
+ makedepends = git
depends = python2-django
- source = django-picklefield-1.0.0.tar.gz::https://github.com/gintas/django-picklefield/archive/v1.0.0.tar.gz
- sha256sums = e5735c69ed5013ccf22b9189e562a250b8f1ed7eaf974e7235cce1ddd595bf35
+ source = git+https://github.com/gintas/django-picklefield.git#tag=v2.0.0
+ sha256sums = SKIP
pkgname = python2-django-picklefield
diff --git a/PKGBUILD b/PKGBUILD
index 24e320733ebd..092d3bfd8775 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=python2-django-picklefield
-pkgver=1.0.0
+pkgver=2.0.0
pkgrel=1
pkgdesc='A pickled object field for Django'
arch=('any')
url='https://github.com/gintas/django-picklefield'
license=('MIT')
depends=('python2-django')
-makedepends=('python2-setuptools')
-source=("django-picklefield-${pkgver}.tar.gz::https://github.com/gintas/django-picklefield/archive/v${pkgver}.tar.gz")
-sha256sums=('e5735c69ed5013ccf22b9189e562a250b8f1ed7eaf974e7235cce1ddd595bf35')
+makedepends=('python2-setuptools' 'git')
+source=("git+https://github.com/gintas/django-picklefield.git#tag=v${pkgver}")
+sha256sums=('SKIP')
build() {
- cd django-picklefield-${pkgver}
+ cd django-picklefield
python2 setup.py build
}
package_python2-django-picklefield() {
- cd django-picklefield-${pkgver}
+ cd django-picklefield
python2 setup.py install --skip-build --root="${pkgdir}" --optimize='1' --skip-build
install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/python2-django-picklefield