summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302016-08-28 01:59:56 +0200
committerM0Rf302016-08-28 01:59:56 +0200
commit42197cda113360d119b33b65c5571b7cb779034f (patch)
treee613f22582650c34c3303fc84142578a4ac8f59b
downloadaur-42197cda113360d119b33b65c5571b7cb779034f.tar.gz
3.12.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b41b8b2db582
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Aug 27 23:59:52 UTC 2016
+pkgbase = python2-dmidecode
+ pkgdesc = Python module to access DMI data
+ pkgver = 3.12.2
+ pkgrel = 1
+ url = https://git.fedorahosted.org/cgit/python-dmidecode.git
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = python2
+ depends = python2
+ depends = dmidecode
+ source = https://github.com/nima/python-dmidecode/archive/v3.12.2.tar.gz
+ md5sums = 458d83ac45316ec40df327b183b2030e
+
+pkgname = python2-dmidecode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b33b4000ac70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: M0Rf30
+
+pkgname=python2-dmidecode
+pkgver=3.12.2
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://git.fedorahosted.org/cgit/python-dmidecode.git"
+pkgdesc="Python module to access DMI data"
+license=('GPL2')
+depends=('python2' 'dmidecode')
+makedepends=('python2')
+source=("https://github.com/nima/python-dmidecode/archive/v$pkgver.tar.gz")
+
+package() {
+ cd $srcdir/python-dmidecode-${pkgver}
+ make build
+ make dmidump
+ python2 src/setup.py install --root=$pkgdir/
+
+}
+
+md5sums=('458d83ac45316ec40df327b183b2030e')