summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2016-09-04 21:10:26 +0200
committerMuflone2016-09-04 21:10:26 +0200
commit3c93bc1370aef7aa77c148ee5c6aaa5dcc9aeb2c (patch)
tree3e34e19c46ec371828127fd8dcd9847c75391285
parent52fe0548f15c1f23ea4c41820c3ce2df2ace0ed2 (diff)
downloadaur-3c93bc1370aef7aa77c148ee5c6aaa5dcc9aeb2c.tar.gz
Updated package python2-docs-devhelp 2.7.12-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
-rw-r--r--layout.html203
-rw-r--r--theme.conf2
4 files changed, 244 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf8c9208426..f379337a8787 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Sep 4 19:09:25 UTC 2016
pkgbase = python2-docs-devhelp
pkgdesc = Set of HTML documentation for Python 2.x with GNOME-Devhelp support.
- pkgver = 2.7.8
- pkgrel = 2
+ pkgver = 2.7.12
+ pkgrel = 1
url = http://docs.python.org/
arch = any
license = GPL
makedepends = python2
- makedepends = svn
+ makedepends = python2-sphinx
provides = python2-docs
options = docs
- source = https://www.python.org/ftp/python/2.7.8/Python-2.7.8.tar.xz
+ source = https://www.python.org/ftp/python/2.7.12/Python-2.7.12.tar.xz
source = devhelp-build-py2.patch
- sha256sums = edde10a0cb7d14e2735e682882d5b287028d1485c456758154c19573db68075a
+ source = layout.html
+ source = theme.conf
+ sha256sums = d7837121dd5652a05fef807c361909d255d173280c4e1a4ded94d73d80a1f978
sha256sums = f5a9fa2dff4b93f3f15067ed775a32fe127858b6d87b05db8a0dc000124c6dab
+ sha256sums = 1d251413d426f4275259596eb22c6bc35986781b1e57c1d07d3bd97ac978108f
+ sha256sums = bf8686e1d34f7a6b0ac3ee3b2ebcd4e99cf1bea0a690a8ba34b3a1dee6e38d6d
pkgname = python2-docs-devhelp
diff --git a/PKGBUILD b/PKGBUILD
index c09e86c1b32b..26295447976e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,49 @@
# Contributor: Arne Caspari <arne.caspari@unicap-imaging.org>
pkgname=python2-docs-devhelp
-pkgver=2.7.8
-pkgrel=2
+pkgver=2.7.12
+pkgrel=1
pkgdesc="Set of HTML documentation for Python 2.x with GNOME-Devhelp support."
arch=('any')
-makedepends=('python2' 'svn')
+makedepends=('python2' 'python2-sphinx')
provides=('python2-docs')
url="http://docs.python.org/"
license=('GPL')
options=('docs')
source=("https://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz"
- "devhelp-build-py2.patch")
-sha256sums=('edde10a0cb7d14e2735e682882d5b287028d1485c456758154c19573db68075a'
- 'f5a9fa2dff4b93f3f15067ed775a32fe127858b6d87b05db8a0dc000124c6dab')
+ "devhelp-build-py2.patch"
+ "layout.html"
+ "theme.conf")
+sha256sums=('d7837121dd5652a05fef807c361909d255d173280c4e1a4ded94d73d80a1f978'
+ 'f5a9fa2dff4b93f3f15067ed775a32fe127858b6d87b05db8a0dc000124c6dab'
+ '1d251413d426f4275259596eb22c6bc35986781b1e57c1d07d3bd97ac978108f'
+ 'bf8686e1d34f7a6b0ac3ee3b2ebcd4e99cf1bea0a690a8ba34b3a1dee6e38d6d')
prepare() {
cd "${srcdir}/Python-${pkgver}"
- patch -Np1 < "${srcdir}/devhelp-build-py2.patch"
+ patch -p1 -i "${srcdir}/devhelp-build-py2.patch"
+ # Add custom Sphinx theme fixed for Devhelp
+ install -m 755 -d "Doc/tools/basic-nodoctype"
+ install -m 644 -t "Doc/tools/basic-nodoctype" "${srcdir}/layout.html"
+ install -m 644 -t "Doc/tools/basic-nodoctype" "${srcdir}/theme.conf"
}
build() {
cd "${srcdir}/Python-${pkgver}/Doc"
- make devhelp PYTHON="python2"
+ make devhelp \
+ PYTHON="python2" \
+ SPHINXBUILD="sphinx-build2" \
+ SPHINXOPTS="-D html_theme_path='tools' -D html_theme='basic-nodoctype'"
}
package() {
- mkdir -p ${pkgdir}/usr/share/doc/python2/html
- mkdir -p ${pkgdir}/usr/share/devhelp/books
- cp -rf ${srcdir}/Python-${pkgver}/Doc/build/devhelp/* ${pkgdir}/usr/share/doc/python2/html/
- find ${pkgdir}/usr/share/doc/python2/html/ -type f -exec chmod 0644 {} \;
- find ${pkgdir}/usr/share/doc/python2/html/ -type d -exec chmod 0755 {} \;
- mv ${pkgdir}/usr/share/doc/python2/html/Python.devhelp.gz ${pkgdir}/usr/share/doc/python2/html/python2.devhelp.gz
- ln -s ../../doc/python2/html ${pkgdir}/usr/share/devhelp/books/python2
+ install -m 755 -d "${pkgdir}/usr/share/doc/python2/html"
+ install -m 755 -d "${pkgdir}/usr/share/devhelp/books"
+ cp -rf "${srcdir}/Python-${pkgver}/Doc/build/devhelp"/* \
+ "${pkgdir}/usr/share/doc/python2/html/"
+ find "${pkgdir}/usr/share/doc/python2/html/" -type f -exec chmod 0644 {} \;
+ find "${pkgdir}/usr/share/doc/python2/html/" -type d -exec chmod 0755 {} \;
+ mv "${pkgdir}/usr/share/doc/python2/html/Python.devhelp.gz" \
+ "${pkgdir}/usr/share/doc/python2/html/python2.devhelp.gz"
+ ln -s "../../doc/python2/html" "${pkgdir}/usr/share/devhelp/books/python2"
}
diff --git a/layout.html b/layout.html
new file mode 100644
index 000000000000..1a8e51ecba48
--- /dev/null
+++ b/layout.html
@@ -0,0 +1,203 @@
+{#
+ basic-no-doctype/layout.html
+ ~~~~~~~~~~~~~~~~~~~
+
+ Sphinx layout template for the default theme without DOCTYPE URIs.
+
+ :copyright: Copyright 2007-2016 by the Sphinx team, see AUTHORS.
+ :copyright: Copyright 2016 by Fabio Castelli (Muflone)
+ :license: BSD, see LICENSE for details.
+#}
+{%- block doctype -%}
+<!DOCTYPE html>
+{%- endblock %}
+{%- set reldelim1 = reldelim1 is not defined and ' &#187;' or reldelim1 %}
+{%- set reldelim2 = reldelim2 is not defined and ' |' or reldelim2 %}
+{%- set render_sidebar = (not embedded) and (not theme_nosidebar|tobool) and
+ (sidebars != []) %}
+{%- set url_root = pathto('', 1) %}
+{# XXX necessary? #}
+{%- if url_root == '#' %}{% set url_root = '' %}{% endif %}
+{%- if not embedded and docstitle %}
+ {%- set titlesuffix = " &#8212; "|safe + docstitle|e %}
+{%- else %}
+ {%- set titlesuffix = "" %}
+{%- endif %}
+
+{%- macro relbar() %}
+ <div class="related" role="navigation" aria-label="related navigation">
+ <h3>{{ _('Navigation') }}</h3>
+ <ul>
+ {%- for rellink in rellinks %}
+ <li class="right" {% if loop.first %}style="margin-right: 10px"{% endif %}>
+ <a href="{{ pathto(rellink[0]) }}" title="{{ rellink[1]|striptags|e }}"
+ {{ accesskey(rellink[2]) }}>{{ rellink[3] }}</a>
+ {%- if not loop.first %}{{ reldelim2 }}{% endif %}</li>
+ {%- endfor %}
+ {%- block rootrellink %}
+ <li class="nav-item nav-item-0"><a href="{{ pathto(master_doc) }}">{{ shorttitle|e }}</a>{{ reldelim1 }}</li>
+ {%- endblock %}
+ {%- for parent in parents %}
+ <li class="nav-item nav-item-{{ loop.index }}"><a href="{{ parent.link|e }}" {% if loop.last %}{{ accesskey("U") }}{% endif %}>{{ parent.title }}</a>{{ reldelim1 }}</li>
+ {%- endfor %}
+ {%- block relbaritems %} {% endblock %}
+ </ul>
+ </div>
+{%- endmacro %}
+
+{%- macro sidebar() %}
+ {%- if render_sidebar %}
+ <div class="sphinxsidebar" role="navigation" aria-label="main navigation">
+ <div class="sphinxsidebarwrapper">
+ {%- block sidebarlogo %}
+ {%- if logo %}
+ <p class="logo"><a href="{{ pathto(master_doc) }}">
+ <img class="logo" src="{{ pathto('_static/' + logo, 1) }}" alt="Logo"/>
+ </a></p>
+ {%- endif %}
+ {%- endblock %}
+ {%- if sidebars != None %}
+ {#- new style sidebar: explicitly include/exclude templates #}
+ {%- for sidebartemplate in sidebars %}
+ {%- include sidebartemplate %}
+ {%- endfor %}
+ {%- else %}
+ {#- old style sidebars: using blocks -- should be deprecated #}
+ {%- block sidebartoc %}
+ {%- include "localtoc.html" %}
+ {%- endblock %}
+ {%- block sidebarrel %}
+ {%- include "relations.html" %}
+ {%- endblock %}
+ {%- block sidebarsourcelink %}
+ {%- include "sourcelink.html" %}
+ {%- endblock %}
+ {%- if customsidebar %}
+ {%- include customsidebar %}
+ {%- endif %}
+ {%- block sidebarsearch %}
+ {%- include "searchbox.html" %}
+ {%- endblock %}
+ {%- endif %}
+ </div>
+ </div>
+ {%- endif %}
+{%- endmacro %}
+
+{%- macro script() %}
+ <script type="text/javascript">
+ var DOCUMENTATION_OPTIONS = {
+ URL_ROOT: '{{ url_root }}',
+ VERSION: '{{ release|e }}',
+ COLLAPSE_INDEX: false,
+ FILE_SUFFIX: '{{ '' if no_search_suffix else file_suffix }}',
+ HAS_SOURCE: {{ has_source|lower }}
+ };
+ </script>
+ {%- for scriptfile in script_files %}
+ <script type="text/javascript" src="{{ pathto(scriptfile, 1) }}"></script>
+ {%- endfor %}
+{%- endmacro %}
+
+{%- macro css() %}
+ <link rel="stylesheet" href="{{ pathto('_static/' + style, 1) }}" type="text/css" />
+ <link rel="stylesheet" href="{{ pathto('_static/pygments.css', 1) }}" type="text/css" />
+ {%- for cssfile in css_files %}
+ <link rel="stylesheet" href="{{ pathto(cssfile, 1) }}" type="text/css" />
+ {%- endfor %}
+{%- endmacro %}
+
+<html{% if language is not none %} lang="{{ language }}"{% endif %}>
+ <head>
+ <meta http-equiv="Content-Type" content="text/html; charset={{ encoding }}" />
+ {{ metatags }}
+ {%- block htmltitle %}
+ <title>{{ title|striptags|e }}{{ titlesuffix }}</title>
+ {%- endblock %}
+ {{ css() }}
+ {%- if not embedded %}
+ {{ script() }}
+ {%- if use_opensearch %}
+ <link rel="search" type="application/opensearchdescription+xml"
+ title="{% trans docstitle=docstitle|e %}Search within {{ docstitle }}{% endtrans %}"
+ href="{{ pathto('_static/opensearch.xml', 1) }}"/>
+ {%- endif %}
+ {%- if favicon %}
+ <link rel="shortcut icon" href="{{ pathto('_static/' + favicon, 1) }}"/>
+ {%- endif %}
+ {%- endif %}
+{%- block linktags %}
+ {%- if hasdoc('about') %}
+ <link rel="author" title="{{ _('About these documents') }}" href="{{ pathto('about') }}" />
+ {%- endif %}
+ {%- if hasdoc('genindex') %}
+ <link rel="index" title="{{ _('Index') }}" href="{{ pathto('genindex') }}" />
+ {%- endif %}
+ {%- if hasdoc('search') %}
+ <link rel="search" title="{{ _('Search') }}" href="{{ pathto('search') }}" />
+ {%- endif %}
+ {%- if hasdoc('copyright') %}
+ <link rel="copyright" title="{{ _('Copyright') }}" href="{{ pathto('copyright') }}" />
+ {%- endif %}
+ <link rel="top" title="{{ docstitle|e }}" href="{{ pathto(master_doc) }}" />
+ {%- if parents %}
+ <link rel="up" title="{{ parents[-1].title|striptags|e }}" href="{{ parents[-1].link|e }}" />
+ {%- endif %}
+ {%- if next %}
+ <link rel="next" title="{{ next.title|striptags|e }}" href="{{ next.link|e }}" />
+ {%- endif %}
+ {%- if prev %}
+ <link rel="prev" title="{{ prev.title|striptags|e }}" href="{{ prev.link|e }}" />
+ {%- endif %}
+{%- endblock %}
+{%- block extrahead %} {% endblock %}
+ </head>
+ <body role="document">
+{%- block header %}{% endblock %}
+
+{%- block relbar1 %}{{ relbar() }}{% endblock %}
+
+{%- block content %}
+ {%- block sidebar1 %} {# possible location for sidebar #} {% endblock %}
+
+ <div class="document">
+ {%- block document %}
+ <div class="documentwrapper">
+ {%- if render_sidebar %}
+ <div class="bodywrapper">
+ {%- endif %}
+ <div class="body" role="main">
+ {% block body %} {% endblock %}
+ </div>
+ {%- if render_sidebar %}
+ </div>
+ {%- endif %}
+ </div>
+ {%- endblock %}
+
+ {%- block sidebar2 %}{{ sidebar() }}{% endblock %}
+ <div class="clearer"></div>
+ </div>
+{%- endblock %}
+
+{%- block relbar2 %}{{ relbar() }}{% endblock %}
+
+{%- block footer %}
+ <div class="footer" role="contentinfo">
+ {%- if show_copyright %}
+ {%- if hasdoc('copyright') %}
+ {% trans path=pathto('copyright'), copyright=copyright|e %}&#169; <a href="{{ path }}">Copyright</a> {{ copyright }}.{% endtrans %}
+ {%- else %}
+ {% trans copyright=copyright|e %}&#169; Copyright {{ copyright }}.{% endtrans %}
+ {%- endif %}
+ {%- endif %}
+ {%- if last_updated %}
+ {% trans last_updated=last_updated|e %}Last updated on {{ last_updated }}.{% endtrans %}
+ {%- endif %}
+ {%- if show_sphinx %}
+ {% trans sphinx_version=sphinx_version|e %}Created using <a href="http://sphinx-doc.org/">Sphinx</a> {{ sphinx_version }}.{% endtrans %}
+ {%- endif %}
+ </div>
+{%- endblock %}
+ </body>
+</html>
diff --git a/theme.conf b/theme.conf
new file mode 100644
index 000000000000..0d8403f0bdfe
--- /dev/null
+++ b/theme.conf
@@ -0,0 +1,2 @@
+[theme]
+inherit = classic