summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-10-16 09:26:35 +0300
committerAchilleas Pipinellis2015-10-16 09:26:35 +0300
commit82e44053bf1408ba180404d26ee34ef1444920ae (patch)
tree649d14e53f6ed0ce461c468387abafb912bc6d7a
downloadaur-82e44053bf1408ba180404d26ee34ef1444920ae.tar.gz
Init import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD35
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a4f1702914b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-dopy
+ pkgdesc = Digital Ocean API Python wrapper
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/dopy
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2
+ depends = python2-requests
+ source = https://pypi.python.org/packages/source/d/dopy/dopy-0.3.6.tar.gz
+
+pkgname = python2-dopy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d9568cafd12f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37ee21157f6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Achilleas Pipinellis <axilleas archlinux info>
+# Cotributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-dopy
+pkgver=0.3.6
+pkgrel=1
+pkgdesc="Digital Ocean API Python wrapper"
+arch=('any')
+depends=('python2' 'python2-requests')
+makedepends=('python2-distribute')
+url="https://pypi.python.org/pypi/dopy"
+license=('MIT')
+source=(https://pypi.python.org/packages/source/d/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+
+prepare() {
+ cd $srcdir/${pkgname#python2-}-$pkgver
+
+ msg 'Fixing Python version...'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python#/usr/bin/python2#g'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/env python#/usr/bin/env python2#g'
+}
+
+build() {
+ cd $srcdir/${pkgname#python2-}-$pkgver
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/${pkgname#python2-}-$pkgver
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}