summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwicast2016-07-26 19:35:01 +0800
committerwicast2016-07-26 19:35:01 +0800
commit001a73213ea1088921ac4237ab379da736e4f69f (patch)
treecf3ae5dfa7e3627528566baefc9861b0f4ba7feb
downloadaur-001a73213ea1088921ac4237ab379da736e4f69f.tar.gz
Init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abdde2fe8673
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-doxytag2zealdb
+ pkgdesc = create sqlite db for docset from a Doxygen tag file
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/doxytag2zealdb
+ arch = any
+ license = GPLv3
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-docopt
+ depends = python2-beautifulsoup4
+ source = doxytag2zealdb.tar.bz2::https://gitlab.com/vedvyas/doxytag2zealdb/repository/archive.tar.bz2?ref=v0.1.2
+ md5sums = a0945a68c248737005f2358a69de9bfc
+
+pkgname = python2-doxytag2zealdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1f3fb92d3fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: wicast C <wicastchen at hotmail dot com>
+
+_pypiname=doxytag2zealdb
+pkgname=("python2-$_pypiname")
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="create sqlite db for docset from a Doxygen tag file"
+arch=(any)
+url="http://pypi.python.org/pypi/$_pypiname"
+license=('GPLv3')
+depends=('python2' 'python2-docopt' 'python2-beautifulsoup4')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("doxytag2zealdb.tar.bz2::https://gitlab.com/vedvyas/doxytag2zealdb/repository/archive.tar.bz2?ref=v${pkgver}")
+md5sums=('a0945a68c248737005f2358a69de9bfc')
+
+
+
+package() {
+
+ cd "$_pypiname-v${pkgver}-d4cef285e34f65de40d4c0bbef0fc5ac39d53c94"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}