summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2015-08-24 21:52:22 -0400
committerbrent s2015-08-24 21:52:22 -0400
commit2e71766a50f71787a792c75e9118d1bd7fd403e3 (patch)
tree51b4ab0ee5b0e4bff0e6354f4d9254ac0e79aa12
downloadaur-2e71766a50f71787a792c75e9118d1bd7fd403e3.tar.gz
initial AUR3 migrate
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b137ca90f4b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-dpkt
+ pkgdesc = This is a Python library for interacting with and creating packets.
+ pkgver = 1.8
+ pkgrel = 0
+ url = http://code.google.com/p/dpkt/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = python2
+ source = http://dpkt.googlecode.com/files/dpkt-1.8.tar.gz
+ md5sums = 0f8e5a4d4b2f5d5faaf7bbfbf3e1e8b7
+
+pkgname = python2-dpkt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc8df2a57671
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Contributor: Wes Brown <wesbrown18@gmail.com>
+pkgname=python2-dpkt
+pkgver=1.8
+pkgrel=0
+pkgdesc="This is a Python library for interacting with and creating packets."
+arch=('i686' 'x86_64')
+url=("http://code.google.com/p/dpkt/")
+license=('custom')
+depends=('python2')
+source=("http://dpkt.googlecode.com/files/dpkt-${pkgver}.tar.gz")
+md5sums=('0f8e5a4d4b2f5d5faaf7bbfbf3e1e8b7')
+
+build() {
+ cd "$srcdir/dpkt-${pkgver}"
+ python2 setup.py build install --root="${pkgdir}" || return 1
+}
+
+# vim:set ts=2 sw=2 et: