summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrrossum2017-04-18 08:36:46 +0200
committerdrrossum2017-04-18 08:36:46 +0200
commit4f16a85403b050391af820ad5fa845fd6fd718ef (patch)
treedacf45a9dc4edaf2990de4faa2cb30610fb4ed50
parent3a7e5bdc19fb2c514a5d574b81c9d2b09c996e32 (diff)
downloadaur-4f16a85403b050391af820ad5fa845fd6fd718ef.tar.gz
split python package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 39 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eb3c9c4d54e..babafb550293 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
# Generated by mksrcinfo v8
-# Mon Mar 13 08:15:15 UTC 2017
+# Tue Apr 18 06:34:59 UTC 2017
pkgbase = python2-dulwich
- pkgdesc = Dulwich is a pure-Python implementation of the Git file formats and protocols.
+ pkgdesc = Pure-Python implementation of the Git file formats and protocols
pkgver = 0.17.1
pkgrel = 1
- url = http://samba.org/~jelmer/dulwich/
+ url = https://www.dulwich.io/
arch = any
license = GPL2
- depends = python2
+ options = !emptydirs
source = https://www.dulwich.io/releases/dulwich-0.17.1.tar.gz
- sha1sums = 3cd487ac54df10be35e5882cb15e54982773b266
+ source = https://www.dulwich.io/releases/dulwich-0.17.1.tar.gz.asc
+ sha256sums = 5d61812a810038b260ee88807fdb39b4d827e2f00fe5907dad22d2733008f3ea
+ sha256sums = SKIP
pkgname = python2-dulwich
+ depends = python2
+
+pkgname = python-dulwich
+ depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 3d2d8199a611..dfd597fc5d98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,35 @@
-pkgname=python2-dulwich
+# Maintainer: Timothée Ravier <tim@siosm.fr>
+
+pkgname=(python2-dulwich python-dulwich)
pkgver=0.17.1
pkgrel=1
-pkgdesc="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+pkgdesc='Pure-Python implementation of the Git file formats and protocols'
arch=('any')
-url="http://samba.org/~jelmer/dulwich/"
+url='https://www.dulwich.io/'
license=('GPL2')
-depends=('python2')
+depends=()
+options=(!emptydirs)
+source=("https://www.dulwich.io/releases/dulwich-${pkgver}.tar.gz"{,.asc})
+validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij
+sha256sums=('5d61812a810038b260ee88807fdb39b4d827e2f00fe5907dad22d2733008f3ea'
+ 'SKIP')
-source=("https://www.dulwich.io/releases/dulwich-$pkgver.tar.gz")
-sha1sums=('3cd487ac54df10be35e5882cb15e54982773b266')
+build() {
+ cd "dulwich-${pkgver}"
+ python2 setup.py build
+ python setup.py build
+}
-package() {
- cd "$srcdir/dulwich-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
+package_python-dulwich() {
+ depends=('python')
+ cd "dulwich-${pkgver}"
+ python setup.py install --root="$pkgdir/" --skip-build --optimize=1
}
+
+package_python2-dulwich() {
+ depends=('python2')
+ cd "dulwich-${pkgver}"
+ python2 setup.py install --root="$pkgdir/" --skip-build --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: