summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-12-19 12:17:17 +0800
committerUniversebenzene2019-12-19 12:17:17 +0800
commit9e012c4c3e2c770ed98f9de32c09ce35520e65ca (patch)
tree360553931a6e52e4cf7acc7a6a8b520ca37c21cd
parent079bbe3640156661e7b1d1dc51ada1225131d0ea (diff)
downloadaur-9e012c4c3e2c770ed98f9de32c09ce35520e65ca.tar.gz
Update to version 0.2.8
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD9
3 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bda46c3f49c6..b2a884091ce8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python2-easyprocess
pkgdesc = EasyProcess is an easy to use python subprocess interface.
- pkgver = 0.2.7
+ pkgver = 0.2.8
pkgrel = 1
url = http://easyprocess.readthedocs.io/en/latest/
arch = any
license = BSD
- makedepends = python2
makedepends = python2-setuptools
makedepends = python2-sphinx
- source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.7.tar.gz
- md5sums = 2e24425df68b9c6ca723b0a3dcdfce5a
+ source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.8.tar.gz
+ md5sums = 2f41d0b795671e648ffb8e54bbe9e31b
pkgname = python2-easyprocess
- depends = python2>=2.6
+ depends = python2>=2.7
depends = python2-setuptools
optdepends = python-easyprocess-doc: Documentation for EasyProcess
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d6e3b36c63a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 8165a72ad098..77b7663d1098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python2-easyprocess
pkgname=('python2-easyprocess' 'python-easyprocess-doc')
-pkgver=0.2.7
+pkgver=0.2.8
pkgrel=1
pkgdesc="EasyProcess is an easy to use python subprocess interface."
arch=('any')
url="http://easyprocess.readthedocs.io/en/latest/"
license=('BSD')
-makedepends=('python2' 'python2-setuptools' 'python2-sphinx')
+makedepends=('python2-setuptools' 'python2-sphinx')
source=("https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-${pkgver}.tar.gz")
-md5sums=('2e24425df68b9c6ca723b0a3dcdfce5a')
+md5sums=('2f41d0b795671e648ffb8e54bbe9e31b')
build() {
cd ${srcdir}/EasyProcess-${pkgver}
@@ -20,7 +20,7 @@ build() {
}
package_python2-easyprocess() {
- depends=('python2>=2.6' 'python2-setuptools')
+ depends=('python2>=2.7' 'python2-setuptools')
optdepends=('python-easyprocess-doc: Documentation for EasyProcess')
cd ${srcdir}/EasyProcess-${pkgver}
@@ -33,6 +33,7 @@ package_python-easyprocess-doc() {
pkgdesc="Documentation for EasyProcess"
cd ${srcdir}/EasyProcess-${pkgver}/build/sphinx
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE.txt
install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
}