summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-01-15 01:37:45 +0800
committerUniversebenzene2020-01-15 01:37:45 +0800
commitb9c0a49150776f88ee49468fd2bac8712cc37262 (patch)
treeb7b9979291a8286a02aea1800e7ab3bf6ea1e5ad
parent9e012c4c3e2c770ed98f9de32c09ce35520e65ca (diff)
downloadaur-b9c0a49150776f88ee49468fd2bac8712cc37262.tar.gz
Update to version 0.2.9
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD14
3 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2a884091ce8..19c0acd8151d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python2-easyprocess
- pkgdesc = EasyProcess is an easy to use python subprocess interface.
- pkgver = 0.2.8
+ pkgdesc = EasyProcess - an easy to use python subprocess interface.
+ pkgver = 0.2.9
pkgrel = 1
url = http://easyprocess.readthedocs.io/en/latest/
arch = any
license = BSD
makedepends = python2-setuptools
makedepends = python2-sphinx
- source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.8.tar.gz
- md5sums = 2f41d0b795671e648ffb8e54bbe9e31b
+ source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.9.tar.gz
+ md5sums = a1008fc7b2cb69ff2f48a5fae201c24d
pkgname = python2-easyprocess
depends = python2>=2.7
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,5 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index 77b7663d1098..c79e1f941326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python2-easyprocess
pkgname=('python2-easyprocess' 'python-easyprocess-doc')
-pkgver=0.2.8
+pkgver=0.2.9
pkgrel=1
-pkgdesc="EasyProcess is an easy to use python subprocess interface."
+pkgdesc="EasyProcess - an easy to use python subprocess interface."
arch=('any')
url="http://easyprocess.readthedocs.io/en/latest/"
license=('BSD')
makedepends=('python2-setuptools' 'python2-sphinx')
+#checkdepends=('python2-pytest' 'python2-nose' 'python2-pyvirtualdisplay')
source=("https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-${pkgver}.tar.gz")
-md5sums=('2f41d0b795671e648ffb8e54bbe9e31b')
+md5sums=('a1008fc7b2cb69ff2f48a5fae201c24d')
build() {
cd ${srcdir}/EasyProcess-${pkgver}
@@ -19,6 +20,13 @@ build() {
python2 setup.py build_sphinx
}
+check() {
+ cd ${srcdir}/EasyProcess-${pkgver}
+
+ python2 setup.py test
+# PYTHONPATH="build/lib" pytest2
+}
+
package_python2-easyprocess() {
depends=('python2>=2.7' 'python2-setuptools')
optdepends=('python-easyprocess-doc: Documentation for EasyProcess')