summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2018-12-23 16:28:17 +0800
committerUniversebenzene2018-12-23 16:28:17 +0800
commitd298037d4a03b0882569494c933e9ee0ceb096cc (patch)
tree0383d641cbabad0aa3bc24195f3f8f983acf837e
parent7f9c3a846faca44a0cd22b193c680f876cd58fd3 (diff)
downloadaur-d298037d4a03b0882569494c933e9ee0ceb096cc.tar.gz
Update to version 0.2.5
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 41 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfc35439e86d..ccc852422555 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,23 @@
# Generated by mksrcinfo v8
-# Sun Feb 4 07:36:27 UTC 2018
+# Sun Dec 23 08:27:31 UTC 2018
pkgbase = python2-easyprocess
pkgdesc = EasyProcess is an easy to use python subprocess interface.
- pkgver = 0.2.3
+ pkgver = 0.2.5
pkgrel = 1
url = http://easyprocess.readthedocs.io/en/latest/
arch = any
license = BSD
+ makedepends = python2
+ makedepends = python2-setuptools
+ makedepends = python2-sphinx
+ source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.5.tar.gz
+ md5sums = b008558a28fe466e7bea271fdea1b460
+
+pkgname = python2-easyprocess
depends = python2>=2.6
depends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-0.2.3.tar.gz
- md5sums = d08c91cbb2cc4603297968e1ed9eac0f
+ optdepends = python-easyprocess-doc: Documentation for EasyProcess
-pkgname = python2-easyprocess
+pkgname = python-easyprocess-doc
+ pkgdesc = Documentation for EasyProcess
diff --git a/PKGBUILD b/PKGBUILD
index 85cb389e0cf0..20a3cac62321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,38 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
-pkgname=python2-easyprocess
-pkgver=0.2.3
+pkgbase=python2-easyprocess
+pkgname=('python2-easyprocess' 'python-easyprocess-doc')
+pkgver=0.2.5
pkgrel=1
pkgdesc="EasyProcess is an easy to use python subprocess interface."
arch=('any')
url="http://easyprocess.readthedocs.io/en/latest/"
license=('BSD')
-depends=('python2>=2.6' 'python2-setuptools')
+makedepends=('python2' 'python2-setuptools' 'python2-sphinx')
source=("https://files.pythonhosted.org/packages/source/E/EasyProcess/EasyProcess-${pkgver}.tar.gz")
-md5sums=('d08c91cbb2cc4603297968e1ed9eac0f')
+md5sums=('b008558a28fe466e7bea271fdea1b460')
-package() {
- cd "${srcdir}/EasyProcess-${pkgver}"
- install -D -m644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+build() {
+ cd ${srcdir}/EasyProcess-${pkgver}
+ python2 setup.py build
+
+ msg "Building Docs"
+ python2 setup.py build_sphinx
+}
+
+package_python2-easyprocess() {
+ depends=('python2>=2.6' 'python2-setuptools')
+ optdepends=('python-easyprocess-doc: Documentation for EasyProcess')
+ cd ${srcdir}/EasyProcess-${pkgver}
+
+ install -D -m644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
+
+package_python-easyprocess-doc() {
+ pkgdesc="Documentation for EasyProcess"
+ cd ${srcdir}/EasyProcess-${pkgver}/build/sphinx
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgbase}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgbase}"
}