summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJurica Bradarić2015-06-16 14:13:11 +0000
committerJurica Bradarić2015-06-16 14:13:11 +0000
commit97e224a7bfe6602ed1056fa3605e0cc62ea308bd (patch)
tree2627cf830bafcf5fc9e084808a507e4be0b4e0ee
downloadaur-97e224a7bfe6602ed1056fa3605e0cc62ea308bd.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
3 files changed, 50 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..be48ff615ee7
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-editrepl
+ pkgdesc = Runs a terminal based editor inside your REPL session
+ pkgver = 2013.06.20
+ pkgrel = 1
+ url = https://github.com/philipbjorge/EditREPL
+ arch = any
+ license = custom: BSD
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/E/EditREPL/EditREPL-2013.06.20.tar.gz
+
+pkgname = python2-editrepl
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b22bca5aab85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-editrepl
+ pkgdesc = Runs a terminal based editor inside your REPL session
+ pkgver = 2013.06.20
+ pkgrel = 1
+ url = https://github.com/philipbjorge/EditREPL
+ arch = any
+ license = custom: BSD
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/E/EditREPL/EditREPL-2013.06.20.tar.gz
+ sha256sums = 2cf966b27768389c82d4197a1df9c37c2b25ac6c4a019468168e93069637fdbb
+
+pkgname = python2-editrepl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f68749d00efc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jurica Bradaric <jbradaric@gmail.com>
+pkgname=python2-editrepl
+pkgver=2013.06.20
+pkgrel=1
+pkgdesc="Runs a terminal based editor inside your REPL session"
+arch=(any)
+url="https://github.com/philipbjorge/EditREPL"
+license=('custom: BSD')
+makedepends=('python2' 'python2-setuptools')
+
+source=("https://pypi.python.org/packages/source/E/EditREPL/EditREPL-$pkgver.tar.gz")
+sha256sums=('2cf966b27768389c82d4197a1df9c37c2b25ac6c4a019468168e93069637fdbb')
+
+build() {
+ cd "$srcdir/EditREPL-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/EditREPL-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}