summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2014-05-31 03:55:39 -0500
committerDoug Newgard2014-05-31 03:55:39 -0500
commit77aa3edf9f2ca61c7a80be66422b4b134cc10cc8 (patch)
tree4fa6855c82ca96ea10e51c7074f66d7f6e386e74
parent6d94bc3361d63528fe7459abcaa0a88a75336913 (diff)
downloadaur-77aa3edf9f2ca61c7a80be66422b4b134cc10cc8.tar.gz
Upstream update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61f84d10200a..33096ab2bad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-efl
pkgdesc = Python bindings for the Enlightenment Foundataion Libraries
- pkgver = 1.9.0
- pkgrel = 2
+ pkgver = 1.10.0
+ pkgrel = 1
url = http://www.enlightenment.org
arch = i686
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = python-efl
license = GPL3
depends = elementary
depends = python-dbus
- source = http://download.enlightenment.org/rel/bindings/python/python-efl-1.9.0.tar.bz2
- sha1sums = 377eb29fd291aa499b6560851b34c8bd90ae8ad8
+ source = http://download.enlightenment.org/rel/bindings/python/python-efl-1.10.0.tar.bz2
+ sha1sums = ff94c3796348dd70545b59660d9d1cc67c1cb849
pkgname = python-efl
diff --git a/PKGBUILD b/PKGBUILD
index d103a7dba13f..8fd42ddfefd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,30 @@
_python=python
_pkgname=python-efl
pkgname=$_python-efl
-pkgver=1.9.0
-pkgrel=2
+pkgver=1.10.0
+pkgrel=1
pkgdesc="${_python^} bindings for the Enlightenment Foundataion Libraries"
arch=('i686' 'x86_64')
url="http://www.enlightenment.org"
license=('LGPL3' 'GPL3')
depends=('elementary' "$_python-dbus")
source=("http://download.enlightenment.org/rel/bindings/python/$_pkgname-$pkgver.tar.bz2")
-sha1sums=('377eb29fd291aa499b6560851b34c8bd90ae8ad8')
+sha1sums=('ff94c3796348dd70545b59660d9d1cc67c1cb849')
build() {
cd "$srcdir/$_pkgname-$pkgver"
+ DISABLE_CYTHON=1 \
$_python setup.py build
}
package() {
cd "$srcdir/$_pkgname-$pkgver"
+ DISABLE_CYTHON=1 \
$_python setup.py install --root="$pkgdir" --optimize=1
# install text files
install -d "$pkgdir/usr/share/doc/$pkgname/"
- install -m644 -t "$pkgdir/usr/share/doc/$pkgname/" AUTHORS README changes.html
+ install -m644 -t "$pkgdir/usr/share/doc/$pkgname/" AUTHORS README.rst changes.html
}