summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-04-04 22:59:06 -0500
committerDoug Newgard2013-04-04 22:59:06 -0500
commit520630d05d8acad61e16e9564b620299cc28fc06 (patch)
tree2eaf612a5d72a2705e2ecfc70774b5d72081e9c1
parent3a983293c94d9007e1aba5c873d52a72cd7b1189 (diff)
downloadaur-520630d05d8acad61e16e9564b620299cc28fc06.tar.gz
Simplify pkgver function
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD4
3 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe523f7d86b7..5d99d54b2dbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-efl-git
pkgdesc = Python bindings for the Enlightenment Foundataion Libraries
- pkgver = 20130322
+ pkgver = 1.7.99.166
pkgrel = 1
url = http://www.enlightenment.org
arch = i686
diff --git a/.gitignore b/.gitignore
index cfd5f1c65302..1561e82616a2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
+*/
*~
-src/
-pkg/
*.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index a12deaadac92..4908edfc725f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-efl-git
_pkgname=python-efl
-pkgver=20130322
+pkgver=1.7.99.166
pkgrel=1
pkgdesc="Python bindings for the Enlightenment Foundataion Libraries"
arch=('i686' 'x86_64')
@@ -18,7 +18,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- echo $(grep -m 1 "version =" setup.py | awk -F \" '{print $2}').$(git rev-list --count HEAD)
+ echo $(awk -F \" '/version =/ {print $2}' setup.py).$(git rev-list --count HEAD)
}
build() {