summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2015-05-23 10:30:58 -0500
committerDoug Newgard2015-05-23 10:30:58 -0500
commita29fa8923d332a32042790e3ec06fe647167e345 (patch)
treeed034824794e4a0800fe1aa49d32eb14961fbe90
parente34484ee5be050927b7b9b5c283565642c0cd9aa (diff)
downloadaur-a29fa8923d332a32042790e3ec06fe647167e345.tar.gz
Use string formatter for printf
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e87ff8632a43..8027f71cb7cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-efl-git
pkgdesc = Python bindings for the Enlightenment Foundation Libraries - Development Version
- pkgver = 1.13.0beta2.a809.8106e2b
+ pkgver = 1.14.0beta1.a914.9a19db3
pkgrel = 1
url = http://www.enlightenment.org
arch = i686
@@ -9,9 +9,9 @@ pkgbase = python-efl-git
license = GPL3
makedepends = git
makedepends = cython
- depends = elementary>=1.13.0beta2.
+ depends = elementary>=1.14.0beta1.
depends = python-dbus
- provides = python-efl=1.13.0beta2.a809.8106e2b
+ provides = python-efl=1.14.0beta1.a914.9a19db3
conflicts = python-efl
source = git://git.enlightenment.org/bindings/python/python-efl.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c053ec2d30ad..95187b5522c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_python=python
_pkgname=python-efl
pkgname=$_python-efl-git
-pkgver=1.13.0beta2.a809.8106e2b
+pkgver=1.14.0beta1.a914.9a19db3
pkgrel=1
pkgdesc="${_python^} bindings for the Enlightenment Foundation Libraries - Development Version"
arch=('i686' 'x86_64')
@@ -22,7 +22,7 @@ pkgver() {
local v_ver=$($_python setup.py -V | sed 's/-//')
[[ "$v_ver" =~ ".99a" ]] || v_ver="${v_ver}.a$(git rev-list --count HEAD)"
- printf "$v_ver.$(git rev-parse --short HEAD)"
+ printf "%s.g%s" "$v_ver" "$(git rev-parse --short HEAD)"
}
build() {