summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2015-02-07 16:57:27 -0600
committerDoug Newgard2015-02-07 16:57:27 -0600
commitbb64778fb41cd4bc936061d857416a534f135463 (patch)
treefec59e37609914338b8529584e57bcad2800252f
parent5756e62e0b602825257759a93a77aaa46cae1867 (diff)
downloadaur-bb64778fb41cd4bc936061d857416a534f135463.tar.gz
New versioning scheme
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14308a3b85cc..b6b92e714579 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-efl-git
pkgdesc = Python bindings for the Enlightenment Foundation Libraries - Development Version
- pkgver = 1.12.99a771.132b772
+ pkgver = 1.13.0beta2.a809.8106e2b
pkgrel = 1
url = http://www.enlightenment.org
arch = i686
@@ -9,9 +9,9 @@ pkgbase = python-efl-git
license = GPL3
makedepends = git
makedepends = cython
- depends = elementary>=1.12.99
+ depends = elementary>=1.13.0bet
depends = python-dbus
- provides = python-efl=1.12.99a771.132b772
+ provides = python-efl=1.13.0beta2.a809.8106e2b
conflicts = python-efl
source = git://git.enlightenment.org/bindings/python/python-efl.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2be0dfa79435..9a364b17586b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_python=python
_pkgname=python-efl
pkgname=$_python-efl-git
-pkgver=1.12.99a771.132b772
+pkgver=1.13.0beta2.a809.8106e2b
pkgrel=1
pkgdesc="${_python^} bindings for the Enlightenment Foundation Libraries - Development Version"
arch=('i686' 'x86_64')
@@ -19,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- printf "$($_python setup.py -V).$(git rev-parse --short HEAD)"
+ local v_ver=$($_python setup.py -V | sed 's/-//')
+ [[ "$v_ver" =~ ".99a" ]] || v_ver="${v_ver}.a$(git rev-list --count HEAD)"
+
+ printf "$v_ver.$(git rev-parse --short HEAD)"
}
build() {