summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2014-12-28 23:27:42 -0600
committerDoug Newgard2014-12-28 23:27:42 -0600
commitfff627fbe746f39610e80ded9065ba422028e762 (patch)
tree31e05c46625ef0c26c26184321ccb252fb0254be
parentd2ebe435c8022868e1df2a511a137456703ec812 (diff)
downloadaur-fff627fbe746f39610e80ded9065ba422028e762.tar.gz
Install correct readme and require correct version of cython
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b945ac4e4cf4..5145f346d9ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-efl-git
pkgdesc = Python bindings for the Enlightenment Foundation Libraries - Development Version
- pkgver = 1.10.99a654.fcbba66
+ pkgver = 1.12.99a720.b642c60
pkgrel = 1
url = http://www.enlightenment.org
arch = i686
@@ -8,10 +8,10 @@ pkgbase = python-efl-git
license = LGPL3
license = GPL3
makedepends = git
- makedepends = cython
+ makedepends = cython<=0.21
depends = elementary>=1.10.99
depends = python-dbus
- provides = python-efl=1.10.99a654.fcbba66
+ provides = python-efl=1.12.99a720.b642c60
conflicts = python-efl
source = git://git.enlightenment.org/bindings/python/python-efl.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 31e175040a8c..9ea6fb84c07f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_python=python
_pkgname=python-efl
pkgname=$_python-efl-git
-pkgver=1.10.99a654.fcbba66
+pkgver=1.12.99a720.b642c60
pkgrel=1
pkgdesc="${_python^} bindings for the Enlightenment Foundation Libraries - Development Version"
arch=('i686' 'x86_64')
url="http://www.enlightenment.org"
license=('LGPL3' 'GPL3')
depends=('elementary>=1.10.99' "$_python-dbus")
-makedepends=('git' "${_python/p/c}")
+makedepends=('git' "${_python/p/c}<=0.21")
provides=("${pkgname%-*}=$pkgver")
conflicts=("${pkgname%-*}")
source=("git://git.enlightenment.org/bindings/python/$_pkgname.git")
@@ -35,5 +35,5 @@ package() {
# install text files
install -d "$pkgdir/usr/share/doc/${pkgname%-*}/"
- install -m644 -t "$pkgdir/usr/share/doc/${pkgname%-*}/" AUTHORS README.rst changes.html
+ install -m644 -t "$pkgdir/usr/share/doc/${pkgname%-*}/" AUTHORS README changes.html
}