summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2015-07-15 17:11:04 +0300
committerHector Mtz-Seara2015-07-15 17:11:04 +0300
commit60d75ccd113ee71777bfcc3c6fae52c83fd02f18 (patch)
tree2b25742c86e75d48893003aa1ca715c261e503b9
downloadaur-60d75ccd113ee71777bfcc3c6fae52c83fd02f18.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8aa722b74680
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-espressopp
+ pkgdesc = ESPResSo++ is an extensible, flexible, fast and parallel simulation software for soft matter research.
+ pkgver = 1.9.2
+ pkgrel = 1
+ url = http://www.espresso-pp.de/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = doxygen
+ depends = fftw
+ depends = openmpi
+ depends = python2
+ depends = boost
+ depends = python2-mpi4py
+ source = http://www.espresso-pp.de/Download/espressopp-1.9.2.tgz
+ sha1sums = 7e9ad6ed25448275fa33e63fbf2e00c9399acf87
+
+pkgname = python2-espressopp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a962f0f8ba37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# PKGBUILD template to install Espresso
+# Maintainer: Hector Martinez-Seara Monne <hseara ##[at]## gmail?com>
+
+pkgname=("python2-espressopp")
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="ESPResSo++ is an extensible, flexible, fast and parallel simulation software for soft matter research."
+url="http://www.espresso-pp.de/"
+license=("GPL")
+arch=(i686 x86_64)
+depends=('fftw' 'openmpi' 'python2' 'boost' 'python2-mpi4py')
+optdepends=()
+makedepends=('cmake' 'doxygen')
+source=(
+http://www.espresso-pp.de/Download/espressopp-${pkgver}.tgz
+)
+sha1sums=('7e9ad6ed25448275fa33e63fbf2e00c9399acf87')
+
+build() {
+
+ #Real Configuration
+ mkdir -p ${srcdir}/python2
+ msg2 "Building python2 version"
+ cd ${srcdir}/python2
+ pwd
+ cmake ../espressopp-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_COMPILER=mpicxx \
+ -DCMAKE_C_COMPILER=mpicc \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DEXTERNAL_BOOST=ON \
+ -DCMAKE_USE_RELATIVE_PATHS=ON
+ make
+}
+
+package() {
+ msg2 "Making python2 executables"
+ cd ${srcdir}/python2
+ make DESTDIR=${pkgdir} install
+ rm -rf ${pkgdir}/usr/bin
+}
+