summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2015-06-10 14:42:53 +0200
committerÉtienne Deparis2015-06-10 14:42:53 +0200
commit2981086aa9be093ab940524258b33488de831949 (patch)
tree48d17453412ee278eb1696f771b0b56e49d2b9f7
downloadaur-2981086aa9be093ab940524258b33488de831949.tar.gz
New pkgbuild version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e05be354ae4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 4.2.1
+# Wed Jun 10 12:42:26 UTC 2015
+pkgbase = python2-exconsole
+ pkgdesc = Emergency/postmortem Python console
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/python-exconsole
+ arch = any
+ license = PSF
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/p/python-exconsole/python-exconsole-0.1.5.tar.gz
+ md5sums = 595c7fd980dd425c541be960e7fd3eee
+
+pkgname = python2-exconsole
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1a710b73f4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Étienne Deparis <etienne [at] depar.is>
+
+pkgname=python2-exconsole
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="Emergency/postmortem Python console"
+license=("PSF")
+url="https://pypi.python.org/pypi/python-exconsole"
+makedepends=('python2-setuptools')
+source=(http://pypi.python.org/packages/source/p/python-exconsole/python-exconsole-$pkgver.tar.gz)
+md5sums=('595c7fd980dd425c541be960e7fd3eee')
+arch=('any')
+options=(!emptydirs)
+
+package() {
+ cd $srcdir/python-exconsole-$pkgver
+
+ find . -type f -exec sed -i \
+ -e'1s|^#!/usr/bin/env python$|#!/usr/bin/env python2|' \
+ -e '1s|^#!/usr/bin/python$|#!/usr/bin/env python2|' \
+ "{}" \;
+
+ python2 setup.py install --root=$pkgdir
+}
+