summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-11-15 18:26:49 +0000
committerGrey Christoforo2015-11-15 18:34:34 +0000
commit17efc8971f9c43c7783f7cd9f649adff5c51182b (patch)
treedc2e523ea3f8a31c1c73c5fe3ce3c15128244b01
downloadaur-17efc8971f9c43c7783f7cd9f649adff5c51182b.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b19365e5d53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-ezdxf
+ pkgdesc = A Python package to create/manipulate DXF drawings.
+ pkgver = 0.6.5
+ pkgrel = 1
+ url = http://bitbucket.org/mozman/ezdxf
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python2
+ source = https://pypi.python.org/packages/source/e/ezdxf/ezdxf-0.6.5.tar.gz
+ md5sums = bd471bd7d433e085b8f6d11ab39055b2
+
+pkgname = python2-ezdxf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..335ec9573de5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3319f9021f70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id$
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=python2-ezdxf
+_pkgname=ezdxf
+pkgver=0.6.5
+pkgrel=1
+pkgdesc="A Python package to create/manipulate DXF drawings."
+arch=('i686' 'x86_64')
+url="http://bitbucket.org/mozman/ezdxf"
+license=('MIT')
+depends=('python2')
+source=(https://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
+md5sums=('bd471bd7d433e085b8f6d11ab39055b2')
+
+prepare() {
+ cp -r "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-py2"
+ # change python to python2
+ find "${_pkgname}-${pkgver}-py2" -name '*.py' -type f -exec \
+ sed -i 's|env python|env python2|' {} \;
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}-py2"
+ python2 setup.py build
+}
+
+package_python2-macs2() {
+ depends=('python2-numpy')
+
+ cd "${srcdir}/${_pkgname}-${pkgver}-py2"
+ python2 setup.py install --root="${pkgdir}"
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}