summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Holthuis2015-06-21 19:42:09 +0200
committerJan Holthuis2015-06-21 19:42:09 +0200
commit1e9b0f0c90dc59c889bd090301a27f55c16120f6 (patch)
tree26d101df53f204bbc3339416fc3864318a74b2a6
downloadaur-1e9b0f0c90dc59c889bd090301a27f55c16120f6.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
3 files changed, 52 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..3be966c6a2f6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-fakeuseragent
+ pkgdesc = Up to date simple useragent faker with real world database.
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/hellysmile/fake-useragent
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ provides = python2-fakeuseragent
+ conflicts = python2-fakeuseragent-git
+ source = https://pypi.python.org/packages/source/f/fake-useragent/fake-useragent-0.0.4.tar.gz
+
+pkgname = python2-fakeuseragent
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf5b68c5fbbe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-fakeuseragent
+ pkgdesc = Up to date simple useragent faker with real world database.
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/hellysmile/fake-useragent
+ arch = any
+ license = Apache
+ makedepends = python2-setuptools
+ depends = python2
+ provides = python2-fakeuseragent
+ conflicts = python2-fakeuseragent-git
+ source = https://pypi.python.org/packages/source/f/fake-useragent/fake-useragent-0.0.4.tar.gz
+ md5sums = 792012fae10935d7dfe0f233c77367ad
+
+pkgname = python2-fakeuseragent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff42d9c03d84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jan Holthuis <holthuis.jan@googlemail.com>
+
+pkgname=python2-fakeuseragent
+_pypiname=fake-useragent
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="Up to date simple useragent faker with real world database."
+arch=('any')
+url="https://github.com/hellysmile/fake-useragent"
+license=('Apache')
+depends=('python2')
+makedepends=('python2-setuptools')
+conflicts=('python2-fakeuseragent-git')
+provides=('python2-fakeuseragent')
+source=("https://pypi.python.org/packages/source/f/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('792012fae10935d7dfe0f233c77367ad')
+
+package() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}