summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2020-02-08 12:38:32 +0100
committerMaxime Gauduin2020-02-08 12:38:32 +0100
commit5f883ace30b3f600a221784d951d4cf90ba77ac9 (patch)
treed64ce77ba147309aa32ae4764a8afbeff218fd8a
downloadaur-5f883ace30b3f600a221784d951d4cf90ba77ac9.tar.gz
move python2-fastimport to aur
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df8970a920f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-fastimport
+ pkgdesc = VCS fastimport/fastexport parser
+ pkgver = 0.9.8
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/fastimport/
+ arch = any
+ license = GPL
+ makedepends = python2-distutils-extra
+ depends = python2
+ source = https://pypi.io/packages/source/f/fastimport/fastimport-0.9.8.tar.gz
+ md5sums = 85a206e92e209937a8dd11ffe8139cf9
+
+pkgname = python2-fastimport
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3ded36580a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Martin Wimpress <code@flexion.org>
+
+_pkgname=fastimport
+pkgname=python2-fastimport
+pkgver=0.9.8
+pkgrel=1
+pkgdesc="VCS fastimport/fastexport parser"
+arch=(any)
+url="https://pypi.python.org/pypi/fastimport/"
+license=('GPL')
+depends=('python2')
+makedepends=('python2-distutils-extra')
+source=("https://pypi.io/packages/source/f/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('85a206e92e209937a8dd11ffe8139cf9')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}