summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2015-07-29 12:04:37 +0200
committerFabio Zanini2015-07-29 12:04:37 +0200
commit613f077cab47cbf1b1a94465daeafdf7d66760dd (patch)
tree0f29e794a91514d1efdf409726d30a076d8a9e98
parentd595fc4b7509e0bf5c2ea79718c4ceab67491068 (diff)
downloadaur-613f077cab47cbf1b1a94465daeafdf7d66760dd.tar.gz
Typos and similia (thanks to xantares)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fba18971706..fb329d2cb439 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
pkgbase = python2-ffpopsim-git
pkgdesc = Fast Forward Population Genetic Simulation
pkgver = 20130404
- pkgrel = 3
+ pkgrel = 4
url = http://webdav.tuebingen.mpg.de/ffpopsim/index.html
arch = i686
arch = x86_64
license = GPL
makedepends = git
makedepends = swig2
+ makedepends = boost
depends = gcc-libs
depends = gsl
- depends = boost
- depends = python2
depends = python2-numpy
optdepends = python2-sphinx: generate python documentation,
optdepends = doxygen: generate C++ documentation,
optdepends = graphviz: generate C++ documentation
provides = python2-ffpopsim
conflicts = python2-ffpopsim
- source = ffpopsim::git+htts://github.com/iosonofabio/ffpopsim.git#branch=master
+ source = ffpopsim::git+https://github.com/iosonofabio/ffpopsim.git
+ md5sums = SKIP
pkgname = python2-ffpopsim-git
diff --git a/PKGBUILD b/PKGBUILD
index be92ea171271..c6b4f5d78db4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Fabio Zanini <fabio.zanini@tuebingen.mpg.de>
pkgname=python2-ffpopsim-git
pkgver=20130404
-pkgrel=3
+pkgrel=4
pkgdesc="Fast Forward Population Genetic Simulation"
arch=('i686' 'x86_64')
url="http://webdav.tuebingen.mpg.de/ffpopsim/index.html"
license=('GPL')
provides=('python2-ffpopsim')
conflicts=('python2-ffpopsim')
-depends=('gcc-libs' 'gsl' 'boost' 'python2' 'python2-numpy')
-makedepends=('git' 'swig2')
+depends=('gcc-libs' 'gsl' 'python2-numpy')
+makedepends=('git' 'swig2' 'boost')
optdepends=('python2-sphinx: generate python documentation',
'doxygen: generate C++ documentation',
'graphviz: generate C++ documentation')
-source=('ffpopsim::git+htts://github.com/iosonofabio/ffpopsim.git#branch=master')
-md5sums=() #generate with 'makepkg -g'
+source=('ffpopsim::git+https://github.com/iosonofabio/ffpopsim.git')
+md5sums=('SKIP')
_gitroot='https://github.com/iosonofabio/ffpopsim.git'
_gitname='ffpopsim'
@@ -29,7 +29,7 @@ build() {
msg "Connecting to GIT server...."
if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
+ cd "$_gitname" && git pull origin master
msg "The local files are updated."
else
git clone "$_gitroot" "$_gitname"
@@ -42,7 +42,7 @@ build() {
git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
cd "$srcdir/$_gitname-build"
- make python
+ make python SWIG=swig-2
}
package() {