summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2015-06-18 12:09:16 +0200
committerFabio Zanini2015-06-18 12:09:16 +0200
commitd595fc4b7509e0bf5c2ea79718c4ceab67491068 (patch)
tree4d9d6f7e8627578f21620abd02044a73e2d0d8ed
downloadaur-d595fc4b7509e0bf5c2ea79718c4ceab67491068.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD53
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fba18971706
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python2-ffpopsim-git
+ pkgdesc = Fast Forward Population Genetic Simulation
+ pkgver = 20130404
+ pkgrel = 3
+ url = http://webdav.tuebingen.mpg.de/ffpopsim/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = swig2
+ depends = gcc-libs
+ depends = gsl
+ depends = boost
+ depends = python2
+ depends = python2-numpy
+ optdepends = python2-sphinx: generate python documentation,
+ optdepends = doxygen: generate C++ documentation,
+ optdepends = graphviz: generate C++ documentation
+ provides = python2-ffpopsim
+ conflicts = python2-ffpopsim
+ source = ffpopsim::git+htts://github.com/iosonofabio/ffpopsim.git#branch=master
+
+pkgname = python2-ffpopsim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be92ea171271
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Fabio Zanini <fabio.zanini@tuebingen.mpg.de>
+pkgname=python2-ffpopsim-git
+pkgver=20130404
+pkgrel=3
+pkgdesc="Fast Forward Population Genetic Simulation"
+arch=('i686' 'x86_64')
+url="http://webdav.tuebingen.mpg.de/ffpopsim/index.html"
+license=('GPL')
+provides=('python2-ffpopsim')
+conflicts=('python2-ffpopsim')
+depends=('gcc-libs' 'gsl' 'boost' 'python2' 'python2-numpy')
+makedepends=('git' 'swig2')
+optdepends=('python2-sphinx: generate python documentation',
+ 'doxygen: generate C++ documentation',
+ 'graphviz: generate C++ documentation')
+source=('ffpopsim::git+htts://github.com/iosonofabio/ffpopsim.git#branch=master')
+md5sums=() #generate with 'makepkg -g'
+
+_gitroot='https://github.com/iosonofabio/ffpopsim.git'
+_gitname='ffpopsim'
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ make python
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ make DESTDIR="$pkgdir/" python-install
+}
+
+# vim:set ts=2 sw=2 et: