summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2017-08-23 12:19:58 +0200
committerCedric Girard2017-08-23 12:19:58 +0200
commitad3d96f53d4e432d3dcaa31598f6e122191fca09 (patch)
tree098a7a61b13ee849da584fa3cd1103b9f036a1d8
downloadaur-ad3d96f53d4e432d3dcaa31598f6e122191fca09.tar.gz
python2 version of first
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c90030bc0f6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-first
+ pkgdesc = Provides a Python function to get the first element of an iterator.
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/hynek/first/
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ source = http://pypi.python.org/packages/source/f/first/first-2.0.1.tar.gz
+ md5sums = eb62baf10657717238f9dc674b8b681f
+
+pkgname = python2-first
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fe54255c950
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=first
+pkgname="python2-${_pkgname}"
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Provides a Python function to get the first element of an iterator."
+arch=('any')
+url="https://github.com/hynek/first/"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("http://pypi.python.org/packages/source/f/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('eb62baf10657717238f9dc674b8b681f')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: