summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2015-06-08 21:01:39 +0200
committerJelle van der Waa2015-06-08 21:01:39 +0200
commitbdaf8e3cef3fcf2b25a86c2069cbf4fa40a96206 (patch)
tree134d0e8704aed382335adf27aec027e1cd8a8ced
downloadaur-bdaf8e3cef3fcf2b25a86c2069cbf4fa40a96206.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD26
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8407c1ee3643
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-flask-restful-swagger
+ pkgdesc = Extrarct swagger specs from your flask-restful project
+ pkgver = 0.15
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/flask-restful-swagger
+ arch = any
+ license = MIT
+ makedepends = python2-distribute
+ depends = python2-flask>=0.8
+ depends = python2-aniso8601
+ source = http://pypi.python.org/packages/source/f/flask-restful-swagger/flask-restful-swagger-0.15.tar.gz
+ source = LICENSE
+ md5sums = a7dd46d8658b1d53667159e711ac48ac
+ md5sums = 66acec11fa3b48aab9f3046ae3a62fc9
+
+pkgname = python2-flask-restful-swagger
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..fbefeff7415d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+The MIT License (MIT)
+
+Copyright (c) 2013 Ran Tavory
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
+FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
+COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..653c459fbc88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
+
+pkgname=python2-flask-restful-swagger
+_pkgname=flask-restful-swagger
+pkgver=0.15
+pkgrel=1
+pkgdesc='Extrarct swagger specs from your flask-restful project'
+url='https://pypi.python.org/pypi/flask-restful-swagger'
+arch=('any')
+license=('MIT')
+makedepends=('python2-distribute')
+depends=('python2-flask>=0.8' 'python2-aniso8601')
+source=("http://pypi.python.org/packages/source/f/$_pkgname/$_pkgname-$pkgver.tar.gz" "LICENSE")
+md5sums=('a7dd46d8658b1d53667159e711ac48ac'
+ '66acec11fa3b48aab9f3046ae3a62fc9')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 $srcdir/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}