summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2022-04-21 14:36:45 +0200
committerCedric Girard2022-04-21 14:36:45 +0200
commitcbc4643e5592b98e7bcff9e4e4e749cc095f06ef (patch)
tree50c873631286ede6ef800e7b875ac990c933f3c2
parent02b51dc9fefcba5e29db1061a97649241f3a26a4 (diff)
downloadaur-python2-flask-restplus.tar.gz
upgpkg: python2-flask-restplus 0.13.0-2
remove python2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 4 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bafbdc2c8f2..57e242555d08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,15 @@
pkgbase = python2-flask-restplus
pkgdesc = custom actions for flask to help manage your application
pkgver = 0.13.0
- pkgrel = 1
+ pkgrel = 2
url = http://pypi.python.org/pypi/Flask-Restplus/
arch = any
license = BSD
makedepends = python
makedepends = python-setuptools
- makedepends = python2
- makedepends = python2-setuptools
source = https://github.com/noirbizarre/flask-restplus/archive/0.13.0.tar.gz
sha256sums = 5fd64c04bf224912965df54d29efbab423e65ea52ec61f37cf5d0aec553723da
-pkgname = python2-flask-restplus
- depends = python2
- depends = python2-flask>=0.8
- depends = python2-six>=1.3.0
- depends = python2-jsonschema
- depends = python2-pytz
- depends = python2-aniso8601>=0.82
-
pkgname = python-flask-restplus
depends = python
depends = python-flask>=0.8
@@ -27,4 +17,3 @@ pkgname = python-flask-restplus
depends = python-jsonschema
depends = python-pytz
depends = python-aniso8601>=0.82
-
diff --git a/PKGBUILD b/PKGBUILD
index ca83d330c497..d38332f09920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,19 @@
# Maintainer: Cedric Girard <girard.cedric@gmail.com>
_pythonmod=flask-restplus
-pkgname=('python2-flask-restplus' 'python-flask-restplus')
+pkgname='python-flask-restplus'
pkgbase='python2-flask-restplus'
pkgver=0.13.0
-pkgrel=1
+pkgrel=2
pkgdesc='custom actions for flask to help manage your application'
arch=('any')
url='http://pypi.python.org/pypi/Flask-Restplus/'
license=('BSD')
-makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
+makedepends=('python' 'python-setuptools')
#source=("https://pypi.io/packages/source/f/flask-restplus/flask-restplus-${pkgver}.tar.gz")
source=("https://github.com/noirbizarre/flask-restplus/archive/${pkgver}.tar.gz")
sha256sums=('5fd64c04bf224912965df54d29efbab423e65ea52ec61f37cf5d0aec553723da')
-check_python2-flask-restplus() {
- checkdepends=('python2-blinker' 'python2-rednose' 'python2-nose' 'python2-mock' 'python2-tzlocal')
- cd ${srcdir}/${_pythonmod}-$pkgver
- python2 ./setup.py test
-}
-
-package_python2-flask-restplus() {
- depends=('python2' 'python2-flask>=0.8' 'python2-six>=1.3.0' 'python2-jsonschema' 'python2-pytz' 'python2-aniso8601>=0.82')
- cd ${srcdir}/${_pythonmod}-$pkgver
- python2 ./setup.py install --root="${pkgdir}" --prefix="/usr"
-
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
-}
-
check_python-flask-restplus() {
checkdepends=('python-blinker' 'python-rednose' 'python-nose' 'python-mock' 'python-tzlocal')
cd ${srcdir}/${_pythonmod}-$pkgver