summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2019-09-25 11:16:52 +0200
committerCedric Girard2019-09-25 11:16:52 +0200
commit02b51dc9fefcba5e29db1061a97649241f3a26a4 (patch)
tree9b8bddb934b6d15cae0f0939a4f267c597cebc5b
parent6f283a27d3d7d91c0103a369747121422e977f46 (diff)
downloadaur-02b51dc9fefcba5e29db1061a97649241f3a26a4.tar.gz
upgpkg: python2-flask-restplus 0.13.0-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63cb2918882d..1bafbdc2c8f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = python2-flask-restplus
pkgdesc = custom actions for flask to help manage your application
- pkgver = 0.11.0
+ pkgver = 0.13.0
pkgrel = 1
url = http://pypi.python.org/pypi/Flask-Restplus/
arch = any
license = BSD
- source = https://github.com/noirbizarre/flask-restplus/archive/0.11.0.tar.gz
- sha1sums = 0851f0516c4208d24fcd98561525a7b6d0054d2d
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = https://github.com/noirbizarre/flask-restplus/archive/0.13.0.tar.gz
+ sha256sums = 5fd64c04bf224912965df54d29efbab423e65ea52ec61f37cf5d0aec553723da
pkgname = python2-flask-restplus
+ depends = python2
depends = python2-flask>=0.8
depends = python2-six>=1.3.0
depends = python2-jsonschema
@@ -16,6 +21,7 @@ pkgname = python2-flask-restplus
depends = python2-aniso8601>=0.82
pkgname = python-flask-restplus
+ depends = python
depends = python-flask>=0.8
depends = python-six>=1.3.0
depends = python-jsonschema
diff --git a/PKGBUILD b/PKGBUILD
index 1b90421730d7..ca83d330c497 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
_pythonmod=flask-restplus
pkgname=('python2-flask-restplus' 'python-flask-restplus')
pkgbase='python2-flask-restplus'
-pkgver=0.11.0
+pkgver=0.13.0
pkgrel=1
pkgdesc='custom actions for flask to help manage your application'
arch=('any')
url='http://pypi.python.org/pypi/Flask-Restplus/'
license=('BSD')
+makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
#source=("https://pypi.io/packages/source/f/flask-restplus/flask-restplus-${pkgver}.tar.gz")
source=("https://github.com/noirbizarre/flask-restplus/archive/${pkgver}.tar.gz")
-sha1sums=('0851f0516c4208d24fcd98561525a7b6d0054d2d')
+sha256sums=('5fd64c04bf224912965df54d29efbab423e65ea52ec61f37cf5d0aec553723da')
check_python2-flask-restplus() {
checkdepends=('python2-blinker' 'python2-rednose' 'python2-nose' 'python2-mock' 'python2-tzlocal')
@@ -20,7 +21,7 @@ check_python2-flask-restplus() {
}
package_python2-flask-restplus() {
- depends=('python2-flask>=0.8' 'python2-six>=1.3.0' 'python2-jsonschema' 'python2-pytz' 'python2-aniso8601>=0.82')
+ depends=('python2' 'python2-flask>=0.8' 'python2-six>=1.3.0' 'python2-jsonschema' 'python2-pytz' 'python2-aniso8601>=0.82')
cd ${srcdir}/${_pythonmod}-$pkgver
python2 ./setup.py install --root="${pkgdir}" --prefix="/usr"
@@ -34,7 +35,7 @@ check_python-flask-restplus() {
}
package_python-flask-restplus() {
- depends=('python-flask>=0.8' 'python-six>=1.3.0' 'python-jsonschema' 'python-pytz' 'python-aniso8601>=0.82')
+ depends=('python' 'python-flask>=0.8' 'python-six>=1.3.0' 'python-jsonschema' 'python-pytz' 'python-aniso8601>=0.82')
cd ${srcdir}/${_pythonmod}-$pkgver
python ./setup.py install --root="${pkgdir}" --prefix="/usr"