summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2015-10-09 15:18:26 +0200
committerCedric Girard2015-10-09 15:18:26 +0200
commit1ed0c36eb416f637342714a5be363093c88b8220 (patch)
treeb1c99db1114bd99ba87da550f4d2cae3e5f5ccdd
downloadaur-1ed0c36eb416f637342714a5be363093c88b8220.tar.gz
first package version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3226a6840866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Oct 9 13:18:17 UTC 2015
+pkgbase = python2-flask-restplus
+ pkgdesc = custom actions for flask to help manage your application
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/Flask-Restplus/
+ arch = any
+ license = BSD
+ makedepends = setuptools
+ depends = python2-flask
+ source = http://pypi.python.org/packages/source/f/flask-restplus/flask-restplus-0.8.0.tar.gz
+ sha1sums = 504f73ef0840478069d6188d582333f1722df45c
+
+pkgname = python2-flask-restplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ea0c360c017
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+pkgname='python2-flask-restplus'
+pkgver='0.8.0'
+pkgrel='1'
+pkgdesc='custom actions for flask to help manage your application'
+arch=('any')
+url='http://pypi.python.org/pypi/Flask-Restplus/'
+license=('BSD')
+depends=('python2-flask')
+makedepends=('setuptools')
+
+source=("http://pypi.python.org/packages/source/f/flask-restplus/flask-restplus-${pkgver}.tar.gz")
+sha1sums=('504f73ef0840478069d6188d582333f1722df45c')
+
+build() {
+ cd "flask-restplus-${pkgver}"
+ python2 ./setup.py build
+}
+
+check() {
+ cd "flask-restplus-${pkgver}"
+ python2 ./setup.py test
+}
+
+package() {
+ cd "flask-restplus-${pkgver}"
+ python2 ./setup.py install --root="${pkgdir}" --prefix="/usr"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim:set ts=2 sw=2 et: