summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-05-16 19:33:56 +0200
committerBenjamin Chrétien2014-05-16 21:03:14 +0200
commit3971a6a46cec73ff21ed4d02fcc079a5f67f669e (patch)
tree28f5a67bfb3bc56414ba183c147a643a4776472c
downloadaur-python2-flowui-git.tar.gz
Update Ipopt + add voidwalker.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7014ea32ed8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-flowui-git
+ pkgdesc = A flow-based data presentation framework for terminals. Git version.
+ pkgver = 0.2.1.d14b2af
+ pkgrel = 1
+ url = http://github.com/dholm/FlowUI/
+ arch = any
+ license = BSD
+ makedepends = python2
+ makedepends = git
+ depends = python2
+ provides = python2-flowui
+ conflicts = python2-flowui
+ source = FlowUI::git+https://github.com/dholm/FlowUI.git
+ md5sums = SKIP
+
+pkgname = python2-flowui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c1fd40686f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=python2-flowui-git
+pkgver=0.2.1.d14b2af
+_pkgver=0.2.1
+pkgrel=1
+pkgdesc="A flow-based data presentation framework for terminals. Git version."
+url="http://github.com/dholm/FlowUI/"
+depends=('python2')
+makedepends=('python2' 'git')
+license=('BSD')
+arch=('any')
+source=("FlowUI::git+https://github.com/dholm/FlowUI.git")
+md5sums=('SKIP')
+
+provides=(python2-flowui)
+conflicts=(python2-flowui)
+
+pkgver() {
+ cd $srcdir/FlowUI
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ printf "%s.%s" "$_pkgver" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/FlowUI
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/FlowUI
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}