summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2016-04-14 17:44:11 -0500
committerXavierCLL2016-04-14 17:44:11 -0500
commit080d534991374dac397de6d92fae233d94275edf (patch)
tree00172dc6070566e4d8d1cd3275ab460579ebfa61
downloadaur-080d534991374dac397de6d92fae233d94275edf.tar.gz
Init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88a02d8c781d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Thu Apr 14 22:38:52 UTC 2016
+pkgbase = python2-fmask
+ pkgdesc = Python modules which makes it easy to write raster processing code in Python
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = http://rioshome.org/
+ arch = any
+ license = GPLv3
+ depends = python2
+ source = https://bitbucket.org/chchrsc/python-fmask/downloads/python-fmask-0.3.0.tar.gz
+ sha256sums = a16cf48111416f8d91dadb415b07778b075b49b0f78013b04ccac9c079995b22
+
+pkgname = python2-fmask
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b80a5ebfe349
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: XavierCLL
+
+pkgname=python2-fmask
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Implementation in Python of the cloud and shadow algorithms known collectively as Fmask"
+arch=('any')
+url="http://pythonfmask.org/"
+license=('GPLv2')
+depends=('python2' 'python2-rios')
+source=("https://bitbucket.org/chchrsc/python-fmask/downloads/python-fmask-$pkgver.tar.gz")
+sha256sums=('a16cf48111416f8d91dadb415b07778b075b49b0f78013b04ccac9c079995b22')
+
+build() {
+ cd python-fmask-$pkgver/
+ python2 setup.py build
+}
+
+package() {
+ cd python-fmask-$pkgver/
+ python2 setup.py install --root="$pkgdir"
+}