summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 21:35:01 +0200
committerAndrzej Giniewicz2015-07-07 21:35:01 +0200
commitfdb822f4167a894d5f8e01af49f46ec88f7b12b1 (patch)
tree8a78a3a2ef34ff88e1a77ea66aa9175b79df9d9d
downloadaur-fdb822f4167a894d5f8e01af49f46ec88f7b12b1.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f5149f93549
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-formlayout
+ pkgdesc = Tiny Python module for creating form dialogs/widgets to edit various type of parameters
+ pkgver = 1.0.15
+ pkgrel = 1
+ url = http://code.google.com/p/formlayout/
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ makedepends = unzip
+ depends = python2-pyqt4
+ options = !emptydirs
+ source = http://formlayout.googlecode.com/files/formlayout-1.0.15.zip
+ md5sums = db2d06281158506bee84732da9888ff0
+
+pkgname = python2-formlayout
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59d3f6216da1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+pkgname=python2-formlayout
+pkgver=1.0.15
+pkgrel=1
+pkgdesc="Tiny Python module for creating form dialogs/widgets to edit various type of parameters"
+arch=('any')
+url="http://code.google.com/p/formlayout/"
+license=('GPL')
+depends=('python2-pyqt4')
+makedepends=('python2-distribute' 'unzip')
+options=(!emptydirs)
+
+source=(http://formlayout.googlecode.com/files/formlayout-$pkgver.zip)
+md5sums=('db2d06281158506bee84732da9888ff0')
+
+build() {
+ cd "$srcdir/formlayout-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/formlayout-$pkgver"
+
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+}
+