summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-02 04:09:40 +0200
committerMarcell Meszaros2022-07-02 04:09:40 +0200
commit63e692acd80b19231b2130943198ccf8cb519728 (patch)
treef73f6762dd8266770037c8b82a7f803d927197ee
parent51170a387b65bb2edf5a43e7ef6078326076a5b9 (diff)
downloadaur-63e692acd80b19231b2130943198ccf8cb519728.tar.gz
0.3.15-7: fix python2 hashbangs
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 911c7e56c0ed..4710fdaa184b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-freezegun
pkgdesc = Support for tests to mock datetime and set fake times values (legacy Python 2 version)
pkgver = 0.3.15
- pkgrel = 6
+ pkgrel = 7
url = https://pypi.org/project/freezegun/0.3.15/
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 7b0c0eb5624a..e44aa182aac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='python2-freezegun'
_name="${pkgname#python2-}"
pkgver=0.3.15
-pkgrel=6
+pkgrel=7
pkgdesc="Let your Python tests travel through time"
pkgdesc="Support for tests to mock datetime and set fake times values (legacy Python 2 version)"
arch=('any')
@@ -26,11 +26,11 @@ b2sums=('d4ed621d2d25ed675758d4385e892fb3af220ecc694310e6124fe1c1bbf3cf02f0088af
prepare() {
cd "${_tarname}"
- echo "Changing hashbangs in *.py files to refer to 'python3'"
- sed -e '1s|#![ ]*/[a-zA-Z0-9./_ ]*python.*|#!/usr/bin/env python3|' \
+ echo "Changing hashbangs in *.py files to refer to 'python2'"
+ sed -e '1s|#![ ]*/[a-zA-Z0-9./_ ]*python.*|#!/usr/bin/env python2|' \
-i $(find . -name '*.py')
- echo "Deleting async modules since they only support Python 3"
+ echo "Deleting async modules since they don't support Python 2"
rm -rv $(find . -name '*_async*.py')
}