summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVisad2015-11-07 22:21:49 +0300
committerVisad2015-11-07 22:21:49 +0300
commita7e024045e612f01d6fd908f484aee7565122d09 (patch)
treeb86152f137dcb156b67c585f07debc8519b13b86
downloadaur-a7e024045e612f01d6fd908f484aee7565122d09.tar.gz
Initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9280187ed21a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-frida
+ pkgdesc = Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 2 version from PyPi
+ pkgver = 5.0.10
+ pkgrel = 1
+ url = http://www.frida.re
+ arch = any
+ license = wxWindows Library License, Version 3.1
+ depends = python2
+ depends = python2-pygments>=2.0.2
+ depends = python2-prompt_toolkit>=0.38
+ depends = python2-colorama>=0.2.7
+ source = https://pypi.python.org/packages/source/f/frida/frida-5.0.10.zip
+ md5sums = d33c5cc14a4dd624ec0a7fa4dedba8ee
+
+pkgname = python2-frida
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05ea7524544b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+_pkgname=frida
+pkgname=python2-$_pkgname
+pkgver=5.0.10
+pkgrel=1
+pkgdesc="Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 2 version from PyPi"
+arch=('any')
+url="http://www.frida.re"
+license=('wxWindows Library License, Version 3.1')
+depends=('python2' 'python2-pygments>=2.0.2' 'python2-prompt_toolkit>=0.38' 'python2-colorama>=0.2.7')
+source=("https://pypi.python.org/packages/source/f/frida/frida-${pkgver}.zip")
+md5sums=('d33c5cc14a4dd624ec0a7fa4dedba8ee')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ # those names have been changed in prompt_toolkit 0.54
+ if [[ $(pacman -Qi --color=never python2-prompt_toolkit | sed -n 2p | cut -d ":" -f2 | tr -d '[[:space:]]' | xargs -I ver vercmp ver 0.54) -ge 0 ]]; then
+ sed -i 's/create_default_application/create_prompt_application/g' frida/repl.py
+ sed -i 's/create_default_output/create_output/g' frida/repl.py
+ fi
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root=$pkgdir --optimize=1 --skip-build
+}