summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralgebro2018-11-03 13:28:30 -0400
committeralgebro2018-11-03 13:28:30 -0400
commit8a048a01cce503b4765ff702f4043f2c9e3a6c00 (patch)
tree58ccd2b9b1758a7580705777cbef32e54e0b6d6e
downloadaur-8a048a01cce503b4765ff702f4043f2c9e3a6c00.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--COPYING50
-rw-r--r--PKGBUILD28
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0704dcb7fbd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python2-frida-tools
+ pkgdesc = Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 2 version
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = http://www.frida.re
+ arch = i686
+ arch = x86_64
+ license = wxWindows Library License, Version 3.1
+ depends = python2
+ depends = python2-pygments
+ depends = python2-prompt_toolkit=1.0.15
+ depends = python2-colorama
+ source = https://files.pythonhosted.org/packages/54/a4/6d0a320c21ba9964b6de1dfa197db7da5397904930c877c250804fcc2807/frida-tools-1.2.2.tar.gz
+ source = COPYING
+ sha256sums = d059760a06a4b01738685973502ea0655f1a49cc50305573c3264f06c1683942
+ sha256sums = 5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2
+
+pkgname = python2-frida-tools
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..b01d49c670e5
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,50 @@
+ wxWindows Library Licence, Version 3.1
+ ======================================
+
+Copyright (c) 1998-2005 Julian Smart, Robert Roebling et al
+
+Everyone is permitted to copy and distribute verbatim copies
+of this licence document, but changing it is not allowed.
+
+ WXWINDOWS LIBRARY LICENCE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+This library is free software; you can redistribute it and/or modify it
+under the terms of the GNU Library General Public Licence as published by
+the Free Software Foundation; either version 2 of the Licence, or (at your
+option) any later version.
+
+This library is distributed in the hope that it will be useful, but WITHOUT
+ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
+Licence for more details.
+
+You should have received a copy of the GNU Library General Public Licence
+along with this software, usually in a file named COPYING.LIB. If not,
+write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth
+Floor, Boston, MA 02110-1301 USA.
+
+EXCEPTION NOTICE
+
+1. As a special exception, the copyright holders of this library give
+permission for additional uses of the text contained in this release of the
+library as licenced under the wxWindows Library Licence, applying either
+version 3.1 of the Licence, or (at your option) any later version of the
+Licence as published by the copyright holders of version 3.1 of the Licence
+document.
+
+2. The exception is that you may use, copy, link, modify and distribute
+under your own terms, binary object code versions of works based on the
+Library.
+
+3. If you copy code from files distributed under the terms of the GNU
+General Public Licence or the GNU Library General Public Licence into a
+copy of this library, as this licence permits, the exception does not apply
+to the code that you add in this way. To avoid misleading anyone as to the
+status of such modified files, you must delete this exception notice from
+such code and/or adjust the licensing conditions notice accordingly.
+
+4. If you write modifications of your own for this library, it is your
+choice whether to permit this exception to apply to your modifications. If
+you do not wish that, you must delete the exception notice from such code
+and/or adjust the licensing conditions notice accordingly.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8bcaf5f3630
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: algebro <algebro at tuta dot io>
+
+_pkgname=frida-tools
+pkgname=python2-$_pkgname
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 2 version"
+arch=('i686' 'x86_64')
+url="http://www.frida.re"
+license=('wxWindows Library License, Version 3.1')
+depends=('python2' 'python2-pygments' 'python2-prompt_toolkit=1.0.15' 'python2-colorama')
+source=("https://files.pythonhosted.org/packages/54/a4/6d0a320c21ba9964b6de1dfa197db7da5397904930c877c250804fcc2807/frida-tools-${pkgver}.tar.gz"
+ "COPYING")
+sha256sums=('d059760a06a4b01738685973502ea0655f1a49cc50305573c3264f06c1683942'
+ '5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python2 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m 644 "COPYING" "$pkgdir/usr/share/licenses/$pkgname/"
+}