summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-12-15 09:53:00 +0100
committerAntonio Rojas2021-12-15 09:53:00 +0100
commit2d32d477d0d9005a3343d7f097590b0f98d49b3b (patch)
treefca52e83d79258697eee1c6921d2ee8596c76281
parent08ffbbf7581b2419f808c04f16cdba563e914600 (diff)
downloadaur-2d32d477d0d9005a3343d7f097590b0f98d49b3b.tar.gz
import from community
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 26 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 358a89983d1b..4f33907a6a7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python2-funcsigs
- pkgdesc = Python function signatures from PEP362 for Python 2.6 and 2.7
- pkgver = 0.4
- pkgrel = 1
- url = http://funcsigs.readthedocs.org
+ pkgdesc = Python function signatures from PEP362
+ pkgver = 1.0.2
+ pkgrel = 3
+ url = https://pypi.python.org/pypi/funcsigs/
arch = any
license = Apache
+ checkdepends = python2-nose
+ checkdepends = python2-unittest2
makedepends = python2-setuptools
depends = python2
- options = !libtool
- source = https://pypi.python.org/packages/source/f/funcsigs/funcsigs-0.4.tar.gz
- md5sums = fb1d031f284233e09701f6db1281c2a5
+ source = https://pypi.python.org/packages/94/4a/db842e7a0545de1cdb0439bb80e6e42dfe82aaeaadd4072f2263a4fbed23/funcsigs-1.0.2.tar.gz
+ sha256sums = a7bb0f2cf3a3fd1ab2732cb49eba4252c2af4240442415b4abce3b87022a8f50
pkgname = python2-funcsigs
-
diff --git a/PKGBUILD b/PKGBUILD
index e7542dda7211..9e770e575a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
+# Maintainer: Jelle van der Waa <jelle@archlinux.org>
pkgname=python2-funcsigs
-pkgver=0.4
-pkgrel=1
-pkgdesc="Python function signatures from PEP362 for Python 2.6 and 2.7"
+pkgver=1.0.2
+pkgrel=3
+pkgdesc="Python function signatures from PEP362"
arch=('any')
-url="http://funcsigs.readthedocs.org"
+url="https://pypi.python.org/pypi/funcsigs/"
+license=('Apache')
depends=('python2')
makedepends=('python2-setuptools')
-license=('Apache')
-options=(!libtool)
-source=(https://pypi.python.org/packages/source/f/funcsigs/funcsigs-${pkgver}.tar.gz)
-md5sums=('fb1d031f284233e09701f6db1281c2a5')
-
-build() {
- cd "${srcdir}"/funcsigs-${pkgver}
-
- python2 setup.py build
-}
+checkdepends=('python2-nose' 'python2-unittest2')
+#source=(https://pypi.python.org/packages/source/f/funcsigs/funcsigs-${pkgver}.tar.gz)
+source=(https://pypi.python.org/packages/94/4a/db842e7a0545de1cdb0439bb80e6e42dfe82aaeaadd4072f2263a4fbed23/funcsigs-1.0.2.tar.gz)
+sha256sums=('a7bb0f2cf3a3fd1ab2732cb49eba4252c2af4240442415b4abce3b87022a8f50')
package() {
- cd "${srcdir}"/funcsigs-${pkgver}
+ cd "$srcdir/funcsigs-$pkgver"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+}
- python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+check() {
+ cd "$srcdir/funcsigs-$pkgver/tests"
+ nosetests2 .
}
+# vim:ts=2:sw=2:et: