summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2022-06-12 01:31:27 -0300
committerDanilo J. S. Bellini2022-06-12 01:31:27 -0300
commit4f844b6346c95181718d47e3adbc2e4153259bae (patch)
treef47db4e509bdcbd117a0fbce55c2886ac7a86788
parentef11a3bf69b8011aed92a495217741dc4e9f3967 (diff)
downloadaur-4f844b6346c95181718d47e3adbc2e4153259bae.tar.gz
Add v1.0.2-4 enabling tests again
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD36
3 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd41604ae741..af633fe644e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python2-funcsigs
pkgdesc = Python function signatures from PEP362
pkgver = 1.0.2
- pkgrel = 3
- url = https://pypi.python.org/pypi/funcsigs/
+ pkgrel = 4
+ url = https://pypi.python.org/pypi/funcsigs
arch = any
license = Apache
+ checkdepends = python2-unittest2
makedepends = python2-setuptools
depends = python2
- source = funcsigs-1.0.2.tar.gz::https://pypi.python.org/packages/source/f/funcsigs/funcsigs-1.0.2.tar.gz
- b2sums = 3006d46018ae040b930e397c3f11575ae0ef18a8b2c9b6c10075804d83d23bea1fb81179de85180146673e0bd4c775a68c0ff624cdaceb1894efe5b2c8fd753c
+ source = https://pypi.python.org/packages/source/f/funcsigs/funcsigs-1.0.2.tar.gz
+ sha256sums = a7bb0f2cf3a3fd1ab2732cb49eba4252c2af4240442415b4abce3b87022a8f50
pkgname = python2-funcsigs
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index ea592917bacb..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,9 +0,0 @@
-*
-!.gitignore
-!.SRCINFO
-!PKGBUILD
-!*.diff
-!*.hook
-!*.install
-!*.patch
-
diff --git a/PKGBUILD b/PKGBUILD
index 13fe9c39b146..abae44a216b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,36 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
# Contributor: Jelle van der Waa <jelle@archlinux.org>
-
pkgname='python2-funcsigs'
_name="${pkgname#python2-}"
pkgver=1.0.2
-pkgrel=3
+pkgrel=4
pkgdesc='Python function signatures from PEP362'
arch=('any')
-url="https://pypi.python.org/pypi/${_name}/"
+_pypi='https://pypi.python.org'
+url="$_pypi/pypi/$_name"
license=('Apache')
depends=('python2')
makedepends=('python2-setuptools')
-# checkdepends=('python2-nose' 'python2-unittest2')
-_tarname="${_name}-${pkgver}"
-source=("${_tarname}.tar.gz::https://pypi.python.org/packages/source/${_name::1}/${_name}/${_tarname}.tar.gz")
-b2sums=('3006d46018ae040b930e397c3f11575ae0ef18a8b2c9b6c10075804d83d23bea1fb81179de85180146673e0bd4c775a68c0ff624cdaceb1894efe5b2c8fd753c')
+checkdepends=('python2-unittest2')
+source=("$_pypi/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a7bb0f2cf3a3fd1ab2732cb49eba4252c2af4240442415b4abce3b87022a8f50')
-package() {
- cd "${_tarname}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+
+ # Skip README doctests (invalid syntax in Python 2.x)
+ sed -i 's-^.*readme-#&-I' tests/test_funcsigs.py
}
-# check() {
-# cd "${_tarname}/tests"
-# nosetests2 .
-# }
+check() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 -m unittest2
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}