summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-14 23:23:54 +0300
committervlad2015-07-14 23:23:54 +0300
commit2285e682e4d57690fb22fa09c45d80f6f86ced7e (patch)
tree65f14dcabd191e48d0f9ee6a5a9427256fe34832
downloadaur-2285e682e4d57690fb22fa09c45d80f6f86ced7e.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..176a874d9b50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-fusepy-git
+ pkgdesc = Simple ctypes bindings for FUSE
+ pkgver = v2.0.2.r1.g27d76e4
+ pkgrel = 1
+ url = https://github.com/terencehonles/fusepy
+ arch = any
+ license = custom:ISCL
+ makedepends = python2-setuptools
+ depends = fuse>=2.6
+ depends = python2
+ conflicts = python2-fuse
+ source = git://github.com/terencehonles/fusepy.git
+ md5sums = SKIP
+
+pkgname = python2-fusepy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afc32b92674c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Nidhogg
+pkgname='python2-fusepy-git'
+pkgver=v2.0.2.r1.g27d76e4
+pkgrel=1
+pkgdesc='Simple ctypes bindings for FUSE'
+arch=('any')
+license=('custom:ISCL')
+url='https://github.com/terencehonles/fusepy'
+depends=('fuse>=2.6' 'python2')
+makedepends=('python2-setuptools')
+conflicts=('python2-fuse')
+source=('git://github.com/terencehonles/fusepy.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fusepy
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/fusepy"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ sed -n '/Copyright/,/ THIS SOFTWARE[.]/p' fuse.py > LICENSE
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: