summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2019-08-30 08:47:57 -0500
committerDoug Newgard2019-08-30 08:47:57 -0500
commit08017b29cafb7e12dc77151916f0a641e510b2c3 (patch)
tree431d35f00d6fd23186851da9fe2bc64e5659d21c
downloadaur-08017b29cafb7e12dc77151916f0a641e510b2c3.tar.gz
Python2 GDAL bindings
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f37d305df40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-gdal
+ pkgdesc = Python2 bindings for GDAL
+ pkgver = 3.0.1
+ pkgrel = 1
+ url = https://gdal.org/
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ depends = gdal
+ depends = glibc
+ depends = python2
+ depends = python2-numpy
+ source = https://download.osgeo.org/gdal/3.0.1/gdal-3.0.1.tar.xz
+ sha256sums = 45b4ae25dbd87282d589eca76481c426f72132d7a599556470d5c38263b09266
+
+pkgname = python2-gdal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..71a9d16c2b38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*/
+*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3844c3c9213b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Doug Newgard <scimmia at archlinux dot org>
+
+pkgname=python2-gdal
+pkgver=3.0.1
+pkgrel=1
+pkgdesc='Python2 bindings for GDAL'
+arch=('x86_64')
+url='https://gdal.org/'
+license=('custom')
+depends=('gcc-libs' 'gdal' 'glibc' 'python2' 'python2-numpy')
+source=("https://download.osgeo.org/gdal/$pkgver/gdal-$pkgver.tar.xz")
+sha256sums=('45b4ae25dbd87282d589eca76481c426f72132d7a599556470d5c38263b09266')
+
+build() {
+ cd gdal-$pkgver/swig/python
+ python2 setup.py build
+}
+
+package() {
+ cd gdal-$pkgver/swig/python
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ cd "$pkgdir/usr/bin/"
+ for bin in *.py; do mv $bin ${bin%.py}2.py; done
+
+ install -dm755 "$pkgdir/usr/share/licenses"
+ ln -s gdal "$pkgdir/usr/share/licenses/$pkgname"
+}