summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2015-06-11 08:57:12 -0700
committerJonathan Yantis2015-06-11 08:57:12 -0700
commitfa52178264d17fea35c4de738c57ab79847280bf (patch)
tree811bba5aaef4afe9a7f4e330624c7c4ba4f58c4c
downloadaur-python2-gdbn-git.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD73
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1d4c50a5d6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-gdbn-git
+ pkgdesc = This package contains Python 2 code for pre-trained deep neural networks. RBM pre-training is supported and backpropagation. There are a handful of possible unit types. For training, minibatched stochastic gradient descent is implemented.
+ pkgver = 0.2dev.0.1.r1.g7b805fa
+ pkgrel = 1
+ url = https://github.com/dnouri/gdbn
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-gnumpy
+ depends = python2-npmat
+ optdepends = python2-cudamat-git: Use GPU instead of CPU
+ provides = python2-gdbn
+ conflicts = python2-gdbn
+ source = git+https://github.com/dnouri/gdbn.git
+ sha256sums = SKIP
+
+pkgname = python2-gdbn-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c16a239f4fab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: jyantis <yantis@yantis.net>
+
+pkgname=python2-gdbn-git
+pkgver=0.2dev.0.1.r1.g7b805fa
+pkgrel=1
+pkgdesc='This package contains Python 2 code for pre-trained deep neural networks. RBM pre-training is supported and backpropagation. There are a handful of possible unit types. For training, minibatched stochastic gradient descent is implemented.'
+arch=('any')
+url='https://github.com/dnouri/gdbn'
+license=('MIT')
+depends=('python2'
+ 'python2-gnumpy'
+ 'python2-npmat'
+ )
+source=('git+https://github.com/dnouri/gdbn.git')
+sha256sums=('SKIP')
+makedepends=('git' 'python2-setuptools')
+provides=('python2-gdbn')
+conflicts=('python2-gdbn')
+optdepends=('python2-cudamat-git: Use GPU instead of CPU')
+
+pkgver() {
+ cd gdbn
+ set -o pipefail
+ _gitversion=$( git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" )
+
+ # If there is a setup.py then pull the version tag from the file
+ if [ -f "setup.py" ]; then
+ if grep --quiet "version = " setup.py; then
+ printf "%s.%s" "$(grep -R "version = " setup.py | awk -F\' '{print $2}')" $_gitversion | sed 's/-/./g'
+ elif grep --quiet "version=" setup.py; then
+ printf "%s.%s" "$(grep -R "version=" setup.py | awk -F\' '{print $2}')" $_gitversion | sed 's/-/./g'
+ else
+ printf "%s" $_gitversion
+ fi
+ else
+ printf "%s" $_gitversion
+ fi
+}
+
+build() {
+ cd gdbn
+
+ # Patch any #!/usr/bin/python to #!/usr/bin/python2
+ for file in $(find . -name '*.py' -print); do
+ sed -r -i 's_^#!.*/usr/bin/python(\s|$)_#!/usr/bin/python2_' $file
+ sed -r -i 's_^#!.*/usr/bin/env(\s)*python(\s|$)_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py build
+}
+
+check() {
+ cd gdbn
+ python2 setup.py test --verbose
+}
+
+package() {
+ cd gdbn
+
+ # We don't need anything related to git in the package
+ rm -rf .git*
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ # Install License
+ install -D -m644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install Documentation
+ install -D -m644 README.txt "${pkgdir}/usr/share/doc/${pkgname}/README.txt"
+}
+
+# vim:set ts=2 sw=2 et: