summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorisrael.herraiz2016-06-09 17:36:10 +0200
committerisrael.herraiz2016-06-09 17:36:10 +0200
commit59bb70eda2dc0a5fa8df9972624865b6b2331554 (patch)
tree00181208bbb91b3e942530d5ff1397f26c38341a
downloadaur-59bb70eda2dc0a5fa8df9972624865b6b2331554.tar.gz
Initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d33fb09c33f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-geohash
+ pkgdesc = Fast, accurate python geohashing library
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/hkwi/python-geohash
+ arch = any
+ license = APACHE
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/74/84/fa80c5e92854c7456b591f6e797c5be18315994afd3ef16a58694e1b5eb1/Geohash-1.0.tar.gz
+ md5sums = a7c4e57874061fae1e30dd8aa8b9b390
+
+pkgname = python2-geohash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6c779b3e401
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=python2-geohash
+pkgver=1.0
+pkgrel=1
+pkgdesc="Fast, accurate python geohashing library"
+arch=('any')
+url="https://github.com/hkwi/python-geohash"
+license=('APACHE')
+groups=()
+depends=('python2')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=('https://pypi.python.org/packages/74/84/fa80c5e92854c7456b591f6e797c5be18315994afd3ef16a58694e1b5eb1/Geohash-1.0.tar.gz')
+md5sums=('a7c4e57874061fae1e30dd8aa8b9b390')
+
+package() {
+ cd "$srcdir/Geohash-$pkgver"
+ /usr/bin/python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: