summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Treinish2015-09-01 15:17:28 -0400
committerMatthew Treinish2015-09-01 15:17:28 -0400
commit9654970cc0c4b7103e60bb5d9ab83dc783fe8815 (patch)
tree789de43559c6e42ebc8c3f57f8bffa77e080c0a0
downloadaur-9654970cc0c4b7103e60bb5d9ab83dc783fe8815.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD16
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47a776f676d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python2-gertty
+ pkgdesc = console-based interface to the Gerrit Code Review system
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/gertty
+ arch = any
+ license = Apache2
+ makedepends = python2
+ makedepends = python2-setuptools
+ depends = python2-gitpython
+ depends = python2-sqlalchemy
+ depends = python2-urwid
+ depends = python2-dateutil
+ depends = python2-requests
+ depends = python2-ordereddict
+ depends = python2-alembic
+ depends = python2-yaml
+ depends = python2-ply
+ depends = python2-voluptuous
+ depends = python2-pbr
+ source = https://pypi.python.org/packages/source/g/gertty/gertty-1.0.3.tar.gz
+ md5sums = 6109bf33ea454d9f148ce47dc12bb654
+
+pkgname = python2-gertty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4d7728b284d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=python2-gertty
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="console-based interface to the Gerrit Code Review system"
+arch=('any')
+url='https://pypi.python.org/pypi/gertty'
+license=('Apache2')
+source=("https://pypi.python.org/packages/source/g/gertty/gertty-$pkgver.tar.gz")
+md5sums=('6109bf33ea454d9f148ce47dc12bb654')
+makedepends=('python2' 'python2-setuptools')
+depends=('python2-gitpython' 'python2-sqlalchemy' 'python2-urwid' 'python2-dateutil' 'python2-requests' 'python2-ordereddict' 'python2-alembic' 'python2-yaml' 'python2-ply' 'python2-voluptuous' 'python2-pbr')
+
+package() {
+ cd $srcdir/gertty-$pkgver
+ pip2 install . --root=$pkdir
+}