summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinRuoshui2018-05-01 11:42:05 +0800
committerLinRuoshui2018-05-01 11:42:05 +0800
commitf5f099aaa2af22f0b0e7f9f8b9b52f37b249b9b1 (patch)
treeddbfaeba8ed16bb644252eca938ba87c17499bf5
downloadaur-python2-gfwlist2privoxy.tar.gz
init commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46b286e65537
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue May 1 03:41:36 UTC 2018
+pkgbase = python2-gfwlist2privoxy
+ pkgdesc = convert gfwlist to privoxy action file
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/snachx/gfwlist2privoxy
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ source = https://files.pythonhosted.org/packages/source/g/gfwlist2privoxy/gfwlist2privoxy-1.0.3.tar.gz
+ md5sums = fe8956e340ed72dd1a662da7a11b20ce
+
+pkgname = python2-gfwlist2privoxy
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66358d7d9c13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: 71e6fd52 <DAStudio.71e6fd52@gmail.com>
+
+pkgbase=('python2-gfwlist2privoxy')
+pkgname=('python2-gfwlist2privoxy')
+_module='gfwlist2privoxy'
+pkgver='1.0.3'
+pkgrel=1
+pkgdesc="convert gfwlist to privoxy action file"
+url="https://github.com/snachx/gfwlist2privoxy"
+depends=('python2')
+makedepends=('python2-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/g/${_module}/${_module}-${pkgver}.tar.gz")
+md5sums=('fe8956e340ed72dd1a662da7a11b20ce')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}