summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2021-06-27 22:24:03 +0200
committerAchilleas Pipinellis2021-06-27 22:24:03 +0200
commitbd1c406bfeac8ef82733edbbb3536fe9de474088 (patch)
tree31aa5b6dc7f6a518c0524889423d3177e9a6a330
parent4869c8ad4d0bdac43f9c7f149263f0a6c96ccc90 (diff)
downloadaur-bd1c406bfeac8ef82733edbbb3536fe9de474088.tar.gz
Update to 2.0.1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD18
3 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44f4f0a16aaf..22f7b5625c5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,12 @@
pkgbase = python2-ghp-import
pkgdesc = Copy your docs directly to the gh-pages branch.
- pkgver = 0.4.1
+ pkgver = 2.0.1
pkgrel = 1
url = http://github.com/davisp/ghp-import
arch = any
- license = custom
- makedepends = python2-distribute
- depends = python2
- conflicts = ghp-import
- replaces = ghp-import
- source = http://pypi.python.org/packages/source/g/ghp-import/ghp-import-0.4.1.tar.gz
- md5sums = 99e018372990c03ab355aa62c34965c5
+ license = APACHE
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/g/ghp-import/ghp-import-2.0.1.tar.gz
+ md5sums = 7a1ad8d268c39c2ade28124651d81821
pkgname = python2-ghp-import
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e57a2f24a2e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/
+src/
+*.gz
+*.xz
+*.tgz
+*.zst
+*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 0aee2b6f4b50..fe0d9d55c6b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,20 @@
-# Maintainer: Axilleas Pipinellis <axilleas@archlinux.info>
+# Maintainer: Achilleas Pipinellis <axilleas archlinux gr>
# Contributor: Julien Nicoulaud <julien.nicoulaud@gmail.com>
pkgname=python2-ghp-import
_pkgname=ghp-import
-pkgver=0.4.1
+pkgver=2.0.1
pkgrel=1
pkgdesc="Copy your docs directly to the gh-pages branch."
arch=(any)
url="http://github.com/davisp/ghp-import"
-license=(custom)
-depends=("python2")
-replaces=("ghp-import")
-conflicts=("ghp-import")
-makedepends=("python2-distribute")
-source=("http://pypi.python.org/packages/source/g/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+license=(APACHE)
+makedepends=("python2-setuptools")
+source=("https://pypi.python.org/packages/source/g/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root="$pkgdir/" --optimize=1
-
- install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-md5sums=('99e018372990c03ab355aa62c34965c5')
+md5sums=('7a1ad8d268c39c2ade28124651d81821')