summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNabil Freij2015-06-26 09:54:42 +0100
committerNabil Freij2015-06-26 09:54:42 +0100
commit64539c6df809759ade6e0fb5a45e8dbef8efcffb (patch)
treeb84c7c4960af9490f4f31befd016fe79ec59a498
downloadaur-64539c6df809759ade6e0fb5a45e8dbef8efcffb.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d854bd080a15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python2-ginga-git
+ pkgdesc = A viewer for astronomical data FITS (Flexible Image Transport System) files.
+ pkgver = 20150421
+ pkgrel = 2
+ url = http://ejeschke.github.io/ginga/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = python2
+ depends = python2-astropy
+ depends = python2-matplotlib
+ depends = python2-scipy
+ provides = python2-ginga
+ conflicts = python2-ginga
+ options = !emptydirs
+ source = git+https://github.com/ejeschke/ginga
+ md5sums = SKIP
+
+pkgname = python2-ginga-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb37a19abc03
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Nabobalis <nabil dot freij at gmail dot com>
+# Contributor: Nabobalis <nabil dot freij at gmail dot com>
+pkgname=python2-ginga-git
+_gitname=ginga
+pkgver=20150421
+pkgrel=2
+pkgdesc=" A viewer for astronomical data FITS (Flexible Image Transport System) files."
+arch=('i686' 'x86_64')
+url="http://ejeschke.github.io/ginga/"
+license=('BSD')
+depends=('python2'
+ 'python2-astropy'
+ 'python2-matplotlib'
+ 'python2-scipy')
+provides=(python2-ginga)
+conflicts=(python2-ginga)
+options=(!emptydirs)
+source=(git+https://github.com/ejeschke/ginga)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+package(){
+ cd $srcdir/ginga
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: