summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdarnold2015-08-25 10:47:48 -0400
committerjdarnold2015-08-25 10:47:48 -0400
commit4b912da2043733fef2054ce382ee39d589c0dff6 (patch)
tree34d9272db2b7c44751ca018351ec8ca7360ff147
parent98f25a05de57afed703b9310672cdcee21816cb3 (diff)
downloadaur-4b912da2043733fef2054ce382ee39d589c0dff6.tar.gz
Update to new packaging using git nomenclature
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD46
2 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3406ae30a02b..ca23b554dae5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python2-gmusicapi-git
pkgdesc = Allows control of Google Music with Python
- pkgver = 20140310
- pkgrel = 2
- url = https://github.com/simon-weber/Unofficial-Google-Music-API
+ pkgver = VERSION
+ pkgrel = 3
+ url = https://github.com/simon-weber/gmusicapi
arch = any
license = BSD
makedepends = python2-setuptools
@@ -24,6 +24,8 @@ pkgbase = python2-gmusicapi-git
provides = python2-gmusicapi
conflicts = python2-gmusicapi
options = !emptydirs
+ source = gmusicapi::git+https://github.com/simon-weber/gmusicapi.git
+ md5sums = SKIP
pkgname = python2-gmusicapi-git
diff --git a/PKGBUILD b/PKGBUILD
index aa81e4d184b9..524fe983a141 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,41 @@
-# Contributor: Atlanis <emallson@archlinux.us>
-_pkgname=python2-gmusicapi
+# Contributor: Jonathan Arnold <jdarnold@archlinux.us>
+# Formerly: Atlanis <emallson@archlinux.us>
+_projectname=gmusicapi
+_pkgname=python2-${_projectname}
pkgname=$_pkgname-git
-pkgver=20140310
-pkgrel=2
+pkgver=VERSION
+pkgrel=3
pkgdesc="Allows control of Google Music with Python"
arch=('any')
-url="https://github.com/simon-weber/Unofficial-Google-Music-API"
+url="https://github.com/simon-weber/gmusicapi"
license=('BSD')
groups=()
depends=('python2' 'python2-validictory' 'python2-decorator' 'mutagen' 'python2-protobuf' 'python2-requests' 'python2-dateutil' 'python2-proboscis' 'python2-oauth2client' 'python2-mock' 'python2-appdirs' 'python2-six' 'python2-httplib2>=0.8' 'python2-gflags')
makedepends=('python2-setuptools' 'git')
optdepends=()
-provides=('python2-gmusicapi')
-conflicts=('python2-gmusicapi')
+provides=($_pkgname)
+conflicts=($_pkgname)
replaces=()
backup=()
options=(!emptydirs)
install=
changelog=
noextract=()
-_gitroot="https://github.com/simon-weber/Unofficial-Google-Music-API.git"
-_gitname="$_pkgname"
+source=("$_projectname::git+https://github.com/simon-weber/gmusicapi.git")
+md5sums=('SKIP')
-package() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
+pkgver() {
+ cd "$srcdir/${_projectname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
+build() {
+ cd "$srcdir/${_projectname}"
- msg "GIT checkout done or server timeout"
- msg "Starting make..."
+}
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
- python2 setup.py install --root="$pkgdir" --optimize=1
+package() {
+ cd "$srcdir/${_projectname}"
+ python2 setup.py install --root="$pkgdir" --optimize=1
}
+