summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalte Bublitz2015-06-22 13:59:54 +0200
committerMalte Bublitz2015-06-22 13:59:54 +0200
commitaf99aac0bf6db18eb091700708cd28675a11d3c8 (patch)
treed3cc11215dd0ca781434eefa2473faf5931b9973
downloadaur-af99aac0bf6db18eb091700708cd28675a11d3c8.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e9b7849566a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-gnupg
+ pkgdesc = The gnupg module allows Python programs to make use of the functionality provided by the GNU Privacy Guard.
+ pkgver = 0.3.7
+ pkgrel = 1
+ url = https://bitbucket.org/vinay.sajip/python-gnupg
+ arch = any
+ license = BSD
+ depends = python2
+ depends = gnupg
+ source = https://bitbucket.org/vinay.sajip/python-gnupg/get/0.3.7.tar.gz
+ md5sums = 16678c63dc07d7ef598d24a45bbf2ac5
+
+pkgname = python2-gnupg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f5c1580b6ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Malte Bublitz <malte70+aur@mcbx.de>
+# Old Maintainer: Tom Vincent <http://tlvince.com/contact/>
+# Contributor: Sven Klomp <mail@klomp.eu>
+
+pkgname=python2-gnupg
+_pkgsrcname=python-gnupg
+pkgver=0.3.7
+pkgrel=1
+pkgdesc="The gnupg module allows Python programs to make use of the functionality provided by the GNU Privacy Guard."
+url="https://bitbucket.org/vinay.sajip/python-gnupg"
+license=("BSD")
+arch=("any")
+depends=('python2' 'gnupg')
+source=("https://bitbucket.org/vinay.sajip/${_pkgsrcname}/get/${pkgver}.tar.gz")
+md5sums=('16678c63dc07d7ef598d24a45bbf2ac5')
+
+build() {
+ cd $srcdir/vinay.sajip-${_pkgsrcname}-????????????/
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/vinay.sajip-${_pkgsrcname}-????????????/
+ python2 setup.py install --prefix=${pkgdir}/usr --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}