summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2021-01-10 12:33:23 +0100
committerJelle van der Waa2021-01-10 12:33:23 +0100
commitce9943946901cbbafb20c985aba2219a24fba369 (patch)
treea8ece615a32b66172836c0a692f27447f93ea557
downloadaur-ce9943946901cbbafb20c985aba2219a24fba369.tar.gz
import from community
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1105643e026
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-gobject2
+ pkgdesc = Legacy Python 2 bindings for GObject
+ pkgver = 2.28.7
+ pkgrel = 6
+ url = https://wiki.gnome.org/Projects/PyGObject
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glib2
+ depends = python2
+ provides = pygobject2-devel=2.28.7-6
+ conflicts = pygobject2-devel
+ replaces = pygobject2-devel<=2.28.7-3
+ source = git+https://gitlab.gnome.org/GNOME/pygobject.git#commit=c9594b6a91e6ca2086fedec2ed8249e0a9c029fc
+ sha256sums = SKIP
+
+pkgname = python2-gobject2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ce12fb498b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=python2-gobject2
+pkgver=2.28.7
+pkgrel=6
+pkgdesc="Legacy Python 2 bindings for GObject"
+url="https://wiki.gnome.org/Projects/PyGObject"
+arch=(x86_64)
+license=(LGPL)
+depends=(glib2 python2)
+makedepends=(git)
+provides=("pygobject2-devel=$pkgver-$pkgrel")
+conflicts=(pygobject2-devel)
+replaces=('pygobject2-devel<=2.28.7-3')
+_commit=c9594b6a91e6ca2086fedec2ed8249e0a9c029fc # tags/PYGOBJECT_2_28_7^0
+source=("git+https://gitlab.gnome.org/GNOME/pygobject.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pygobject
+ git describe --tags | sed 's/^PYGOBJECT_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd pygobject
+ find . \( -name '*.py' -o -name '*.py.in' \) -exec sed -i '1s|python$|&2|' {} +
+ autoreconf -fvi
+}
+
+build() (
+ cd pygobject
+ CPPFLAGS+=' -Wno-deprecated-declarations'
+ ./configure --prefix=/usr --disable-introspection PYTHON=/usr/bin/python2
+ sed -i 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+)
+
+package_python2-gobject2() {
+ cd pygobject
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir/usr/share/gtk-doc"
+}