summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Savannah2017-11-19 21:17:54 -0500
committerTim Savannah2017-11-19 21:17:54 -0500
commit636cce1630b5d6d6819f0b18f1acfefd692a72e1 (patch)
tree8bc43f4da79f275ed83c791b5c54259f381d80ea
parenta3639d37e69bc838a6f72dcc845b0bc84e2712f8 (diff)
downloadaur-636cce1630b5d6d6819f0b18f1acfefd692a72e1.tar.gz
Update GoodTests to 2.2.0, and fixup location of distrib/runTests.py. A separate one isnt required for python2 vs python3 anymore (except for ./runTests.py execution), as it will execute tests using the python provided ( so python2 runTests.py executes in py2, python3 runTests.py in py3), but as the python2 and python3 packages dont depend on eachother, might as well ship a native copy of runTests.py with each.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e33571f13504..07fe54a9ef79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-goodtests
pkgdesc = A fast, parallel, featured python unit-testing framework (python2 version)
- pkgver = 2.1.1
+ pkgver = 2.2.0
pkgrel = 1
url = http://github.com/kata198/GoodTests
arch = any
@@ -9,8 +9,8 @@ pkgbase = python2-goodtests
makedepends = python2
depends = python2-setuptools
depends = python2
- source = https://github.com/kata198/GoodTests/archive/2.1.1.tar.gz
- sha512sums = 1c3fa63318d4395b7ab85d3a3c87ba34d1f3dab9d3854af4984074e14673c3b82d39a4d632ac46d1f36c136b835b05797a96a4f801f4b87f607ed1c5122c4af7
+ source = https://github.com/kata198/GoodTests/archive/2.2.0.tar.gz
+ sha512sums = 1698d96cb2807a344540216057b3a6e76aa06ce8622f2d72dd06229740678dad364b0ab579fb2cc7ed96ba1670aa0c5dc0d6e51bf494ecff77cd3f37183171d9
pkgname = python2-goodtests
diff --git a/PKGBUILD b/PKGBUILD
index 58f15866b4a0..24ede6a24de6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python2-goodtests
_realName=GoodTests
-pkgver=2.1.1
+pkgver=2.2.0
pkgrel=1
pkgdesc="A fast, parallel, featured python unit-testing framework (python2 version)"
arch=('any')
@@ -11,7 +11,7 @@ url="http://github.com/kata198/GoodTests"
makedepends=('python2-setuptools' 'python2')
depends=('python2-setuptools' 'python2')
source=("https://github.com/kata198/GoodTests/archive/${pkgver}.tar.gz")
-sha512sums=("1c3fa63318d4395b7ab85d3a3c87ba34d1f3dab9d3854af4984074e14673c3b82d39a4d632ac46d1f36c136b835b05797a96a4f801f4b87f607ed1c5122c4af7")
+sha512sums=("1698d96cb2807a344540216057b3a6e76aa06ce8622f2d72dd06229740678dad364b0ab579fb2cc7ed96ba1670aa0c5dc0d6e51bf494ecff77cd3f37183171d9")
build() {
cd "$srcdir/${_realName}-$pkgver"
@@ -24,8 +24,8 @@ package() {
mv "${pkgdir}/usr/bin/GoodTests.py" "${pkgdir}/usr/bin/GoodTests2.py"
- mkdir -p "${pkgdir}/usr/share/GoodTests2.py"
- install -m 755 distrib/runTests.py "${pkgdir}/usr/share/GoodTests2.py"
+ mkdir -p "${pkgdir}/usr/share/GoodTests2"
+ install -m 755 distrib/runTests.py "${pkgdir}/usr/share/GoodTests2/runTests.py"
- sed 's|^#!/usr/bin/env python|#!/usr/bin/env python2|' -i "${pkgdir}/usr/share/GoodTests2.py/runTests.py"
+ sed 's|^#!/usr/bin/env python|#!/usr/bin/env python2|' -i "${pkgdir}/usr/share/GoodTests2/runTests.py"
}