summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormitts2016-11-27 13:23:53 -0800
committermitts2016-11-27 13:23:53 -0800
commit1143cbdef0ec2ffb5a6e73f4627de669e9c51b0d (patch)
tree602810d4e1a1de4d8db0c4f5bcebfe245f80ad7e
parent8c84c2f78ddcb9b5eb7e61b26e2ac26866c1a66c (diff)
downloadaur-1143cbdef0ec2ffb5a6e73f4627de669e9c51b0d.tar.gz
update, clean up pkgbuild, install license
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 21 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae6ed647bfcf..f00797d0c381 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Mar 31 11:53:12 UTC 2016
pkgbase = python2-gpsoauth
- pkgdesc = client library for Google Play Services OAuth
- pkgver = 0.2.0
- pkgrel = 2
+ pkgdesc = A python client library for Google Play Services OAuth.
+ pkgver = 0.4.0
+ pkgrel = 1
url = https://github.com/simon-weber/gpsoauth
arch = any
- license = BSD
+ license = GPL
makedepends = python2-setuptools
- depends = python2
- depends = python2-requests>=2.9
- depends = python2-pycryptodomex
- options = !emptydirs
- source = https://pypi.python.org/packages/source/g/gpsoauth/gpsoauth-0.2.0.tar.gz
- md5sums = 549da992b843cb3bc5973145104cd77e
+ depends = python2-pycryptodomex>=3.0
+ depends = python2-requests
+ source = https://github.com/simon-weber/gpsoauth/archive/0.4.0.tar.gz
+ md5sums = f9b17147ab28aa4e7b7831b86affebf2
pkgname = python2-gpsoauth
diff --git a/PKGBUILD b/PKGBUILD
index c59f305b847d..99edf10d353c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,21 @@
-# Maintainer: A. Richard <dubitae@gmail.com>
+# Maintainer: mitts <mittens2001@opmbx.org>
+
pkgname=python2-gpsoauth
-_pipyname=gpsoauth
-pkgver=0.2.0
-pkgrel=2
-pkgdesc="client library for Google Play Services OAuth"
+_pkgname=gpsoauth
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A python client library for Google Play Services OAuth."
arch=('any')
url="https://github.com/simon-weber/gpsoauth"
-license=('BSD')
-groups=()
-depends=(
- 'python2'
- 'python2-requests>=2.9'
- 'python2-pycryptodomex'
-)
+license=('GPL')
+depends=('python2-pycryptodomex>=3.0' 'python2-requests')
makedepends=('python2-setuptools')
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-changelog=
-source=("https://pypi.python.org/packages/source/g/$_pipyname/$_pipyname-$pkgver.tar.gz")
-noextract=()
-md5sums=('549da992b843cb3bc5973145104cd77e')
+source=("https://github.com/simon-weber/$_pkgname/archive/$pkgver.tar.gz")
+md5sums=('f9b17147ab28aa4e7b7831b86affebf2')
package() {
- cd "$srcdir/$_pipyname-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver"
python2 setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}